Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I used to have dockbarX applet installed on my gnome panel. However one day when I login in I got a error message which can be seen in the screenshot below. So I removed it, and then tried adding it again to the gnome panel but I still get the error message.

I am running the latest version of dockbarX 0.43 on Ubuntu 10.10 Maverick Meerkat with the helpers enabled and media buttons etc. I did not update it recently and have been using this version for a couple of weeks now and got this problem only now.

I tried a reinstall of all the components of dockbarX but still get the error message.

Here is the ~/.dockbarx/log/dockbarx.log

ERROR   | 2011-03-02 12:10:18,984   | Traceback (most recent call last):
ERROR   | 2011-03-02 12:10:18,985   |   File "/usr/bin/dockbarx_factory", line 31, in <module>
ERROR   | 2011-03-02 12:10:18,985   |     import dockbarx.dockbar
ERROR   | 2011-03-02 12:10:18,985   |   File "/usr/lib/pymodules/python2.6/dockbarx/dockbar.py", line 37, in <module>
ERROR   | 2011-03-02 12:10:19,187   |     from groupbutton import *
ERROR   | 2011-03-02 12:10:19,187   |   File "/usr/lib/pymodules/python2.6/dockbarx/groupbutton.py", line 40, in <module>
ERROR   | 2011-03-02 12:10:19,324   |     import zg
ERROR   | 2011-03-02 12:10:19,324   |   File "/usr/lib/pymodules/python2.6/dockbarx/zg.py", line 34, in <module>
ERROR   | 2011-03-02 12:10:19,399   |     iface = client.ZeitgeistDBusInterface()
ERROR   | 2011-03-02 12:10:19,400   |   File "/usr/lib/pymodules/python2.6/zeitgeist/client.py", line 184, in __init__
ERROR   | 2011-03-02 12:10:19,428   |     self.OBJECT_PATH)
ERROR   | 2011-03-02 12:10:19,428   |   File "/usr/lib/pymodules/python2.6/dbus/bus.py", line 244, in get_object
ERROR   | 2011-03-02 12:10:19,496   |     follow_name_owner_changes=follow_name_owner_changes)
ERROR   | 2011-03-02 12:10:19,496   |   File "/usr/lib/pymodules/python2.6/dbus/proxies.py", line 241, in __init__
ERROR   | 2011-03-02 12:10:19,520   |     self._named_service = conn.activate_name_owner(bus_name)
ERROR   | 2011-03-02 12:10:19,520   |   File "/usr/lib/pymodules/python2.6/dbus/bus.py", line 183, in activate_name_owner
ERROR   | 2011-03-02 12:10:19,520   |     self.start_service_by_name(bus_name)
ERROR   | 2011-03-02 12:10:19,520   |   File "/usr/lib/pymodules/python2.6/dbus/bus.py", line 281, in start_service_by_name
ERROR   | 2011-03-02 12:10:19,521   |     'su', (bus_name, flags)))
ERROR   | 2011-03-02 12:10:19,521   |   File "/usr/lib/pymodules/python2.6/dbus/connection.py", line 620, in call_blocking
ERROR   | 2011-03-02 12:10:19,574   |     message, timeout)
ERROR   | 2011-03-02 12:10:19,575   | dbus.exceptions.DBusException: org.freedesktop.DBus.Error.Spawn.ExecFailed: Failed to execute program /usr/local/bin/zeitgeist-daemon: Success

How can I solve this problem?

enter image description here

share|improve this question
    
To be able to solve this problem you need to post your log. Look in ~/.dockbarx/log/dockbarx.log –  M7S Mar 2 '11 at 10:09
    
What ubuntu version youre using? I got the same problem on maverick few days ago, and still cant get it works; Instead on Lucid docbarx still works perfectly –  Strae Mar 2 '11 at 11:53
    
Then I suppose a common update or something seems to have broken it...I am waiting for the reply from the developer. –  nik90 Mar 2 '11 at 12:05

1 Answer 1

up vote 2 down vote accepted

Ok, that's a known problem. There's a bug in zeitgeist and DockbarX 0.43 don't handle that error as it should. Next version will simply not use zeitgeist if there's an error instead of crashing.

It might take a while before the next release of DockbarX (I'm doing some code cleanup that is much more work than I suspected). In the mean time, try to install zeitgeist from the ppa (ppa:zeitgeist/ppa) or remove the ppa and downgrade zeitgest to mavericks own version if you already use the ppa.

share|improve this answer
    
what is the version of zeitgeist that you recommend? –  nik90 Mar 2 '11 at 14:31
    
I don't remember if this problem has been in zeitgeist ppa or in the version in maverick repository. Just switch to the other one which ever you use and see if it works. –  M7S Mar 2 '11 at 15:58
    
Did you get it to work? –  M7S Mar 3 '11 at 6:09
    
yes it is working now...thnx –  nik90 Mar 5 '11 at 23:45
    
Looking forward to your next release :) –  nik90 Mar 5 '11 at 23:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.