Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've brand new ASUS X501A and Ubuntu 12.04 (and i'm bad in Ubuntu) and the WiFi is extremely slow - 1Mb/s. WiFi chip is RT5390.

I tried everything i found in the net, so i need step by step instructions.

pabris@OrientExpress-Ernests:~$ sudo lshw -c network
  *-network               
       description: Wireless interface
       product: RT5390 Wireless 802.11n 1T/1R PCIe
       vendor: Ralink corp.
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: wlan0
       version: 00
       serial: a4:17:31:50:11:66
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=rt2800pci driverversion=3.5.0-23-generic firmware=0.34 ip=192.168.1.102 latency=0 link=yes multicast=yes wireless=IEEE 802.11bgn
       resources: irq:17 memory:f7d00000-f7d0ffff
  *-network
       description: Ethernet interface
       product: RTL8111/8168B PCI Express Gigabit Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0.2
       bus info: pci@0000:03:00.2
       logical name: eth0
       version: 0a
       serial: 08:60:6e:99:fd:a4
       size: 100Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full firmware=rtl8411-1_0.0.2 03/27/12 ip=192.168.1.101 latency=0 link=yes multicast=yes port=MII speed=100Mbit/s
       resources: irq:42 ioport:e000(size=256) memory:f0004000-f0004fff memory:f0000000-f0003fff
share|improve this question
    
You say you tried everything on the net. Please describe what you tried exactly. People here probably can't read your mind... –  Sander Steffann Apr 26 '13 at 21:19
    
For example these 3 steps: unixmen.com/… –  pabris Apr 27 '13 at 10:21
    
first i install Ubuntu 12.10, than upgrade to 13.04,than install 12.04 LTS over. I found manufacturers driver here mediatek.com/_en/07_downloads/01_windows.php?sn=501 , but i have no idea how to install it manually –  pabris Apr 27 '13 at 10:30

1 Answer 1

I also have an ASUS X501A and I had the same problem with the wireless being slow.

I followed the instructions from this post: Not Able to get wifi working under 13.04 (Ralink rt5390)

Basically you do the following (taken from above post):

  1. Enter your name and email and download driver at: http://www.mediatek.com/_en/07_downl...il.php?sn=5001
  2. Go to the download directory and run these commands

    tar -xvf 2011_1007_RT5390_RT5392_Linux_STA_V2.5.0.3_DPO_v2.bz2.bz2
    cd 2011_1007_RT5390_RT5392_Linux_STA_V2.5.0.3_DPO
    wget http://gridlox.net/diff/rt5592sta_fix_64bit_3.8.patch
    patch -p1 <rt5592sta_fix_64bit_3.8.patch
    

    If patch asks for directory point it to pci_main_dev.c

  3. Make sure ./os/linux/config.mk reads HAS_NATIVE_WPA_SUPPLICANT_SUPPORT=y

  4. Build and install the driver:

    make
    sudo make install
    sudo modprobe rt5390sta
    

    I got various compiler warnings and an error message at the end of the make command saying I didn't have enough permissions but it worked after the sudo make install.

  5. Blacklist the concflicting kernel modules so run

    sudo gedit /etc/modprobe.d/blacklist.conf
    

    And then at the end of the file, add these lines:

    # Blacklist conflicting kernel modules
    blacklist rt2800pci
    blacklist rt2800lib
    blacklist rt2x00usb
    blacklist rt2x00pci
    blacklist rt2x00lib
    blacklist rt2860sta
    blacklist rt3090st
    
  6. Reboot and it should now have faster wireless. I had to re-enter my wireless password but it worked great.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.