Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

All the docs say is

If you are using MAAS to control DHCP, you need to set this via the web interface.

But I see no mention of DHCP in the web interface. What exactly do you click on to configure DHCP?

share|improve this question

2 Answers 2

up vote 3 down vote accepted

I think I figured it out:

  1. Click on the unlabeled gear icon.
  2. Under the Cluster controllers section, click the small grey edit button.
  3. Under the Interfaces section, add or edit a network interface.
  4. Set Management to Manage DHCP.
share|improve this answer
    
In precise i can not see Cluster controllers under the gear icon . –  Omid Kosari May 8 '13 at 8:54
    
this was the answer for me –  ringe Aug 16 '13 at 7:27

Wes, thanks for asking this question and for answering it! You led me down the right path. I'll detail what I did after I followed the steps you gave. I initially tried to get this working by just installing the maas-dhcp package, but it would start b/c a bunch of conf files were missing.

First I followed your steps:

  • Click on the unlabeled gear icon
  • Under the Cluster controllers section, click the small grey edit button.
  • Under the Interfaces section, add or edit a network interface.
  • Set Management to Manage DHCP

After I entered all the details for the DHCP server, I restarted MAAS and it wouldn't work. So, I went back and noticed on that edit page for the region controller it said:

If you enable DHCP management, you will need to install the 'maas-dhcp' package on this cluster controller. Similarly, you will need to install the 'maas-dns' package on this region controller to be able to enable DNS management.

So I did:

sudo apt-get install maas-dhcp maas-dns

And I finally got a node to get an address from it.

share|improve this answer
    
Update: The above is all correct and true, nodes can get an IP address via PXE booting, but they don't show up. Front page of MAAS still says "0 nodes in MAAS". To be clear, I can boot a node to a Raring CD and find the MAAS server. The node shuts down, but doesn't show up in the MAAS web ui. I'm using MAAS on Raring Ringtail with a Virtualbox MAAS Server and Virtualbox nodes. I'm booting the nodes to the same Raring Ringtail Server CD that I used to create the MAAS Server. –  Ian D. Rossi May 3 '13 at 20:08
    
Please add this detail to your answer! Leaving a half-answer as a comment can often cause more harm than good. Thanks. –  Basharat Sialvi May 8 '13 at 9:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.