Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a little problem with my vim config.

This what I got in my home/user/.gvimrc

syntax enable "Enable syntax hl


colorscheme peaksea

set background=dark

set gfn=Inconsolata:h11

set nonu



set history=1000

set scrolloff=3

set number " turn on line numbers

" Save a global session file on session close
nmap SQ <ESC>:mksession! ~/.vim/session/Session.vim<CR>:wqa<CR>

function! RestoreSession()
  if argc() == 0 "vim called without arguments
    execute 'source ~/.vim/session/Session.vim'
  end
endfunction
autocmd VimEnter * call RestoreSession()

The colorsheme work, but the font has way to much spacing. Every sentence is twice as long. I installed the Inconsolata font and I have the same config on my windows 7 box and it works fine.

share|improve this question

1 Answer 1

You're using the wrong format for the 'guifont' setting. The format FontName:h10 works for Windows, but not *nix. Instead, use :set gfn=* to bring up the font dialog to choose your font and size. Then you can check the correct format for your current OS. Or you can read :help 'gfn'.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.