Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Just upgraded from 12.10 to 13.04 on Dell xps13 ultrabook and the display is very dim and cannot be changed using f'n keys or from system settings. This ultrabook uses Intel's ivybridge mobile.

UPDATE: With the intention of reloading 12.04 I had to change the boot params to boot from usb stick. So: secure boot: disabled load legacy rom option: enabled boot list option: UEFI UEFI boot: Must have not quite got params right since it booted from the ssd drive BUT this time display was normal and could up/down brightness? So need to investigate this more by playing with boot params but haven't time or patience now. Andrew

share|improve this question
add comment

2 Answers

I had the same issue on my XP13 (2013 w/ Ivy bridge). With the "load legacy rom" option disabled, the brightness wave very low (even lower than it can normally go?) and was not adjustable.

I can confirm that re-enabling the legacy rom option restores brightness control on my system. I did have a number of other fixes applied (such as http://askubuntu.com/questions/286343/screen-brightness-very-dim-on-a-dell-xps-13-2013 and http://www.webupd8.org/2012/08/fix-dell-xps-13-backlight-brightness.html and http://ubuntuforums.org/showthread.php?t=2139456), but none of them worked until I re-enabled this option.

This is on what I believe to be an EFI booted system (GPT partition table, /sys/firmware/efi exists, etc).

share|improve this answer
    
This worked for me. Thanks! –  Bealer May 29 '13 at 23:14
add comment

I had this issue this morning after doing a fresh install of 13.04. I couldn't figure it out, but it did resolve itself a few hours after. The only real major change I made was installing the 32-bit libraries. So give that a shot.

sudo apt-get install ia32-libs
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.