Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I Installed Ubuntu 13.04 64 bit Unity Desktop environment and did the routine OS update.

Downloaded the 64 bit .deb file from google chrome website and tried installing it ,which resulted to the following error. I am guessing that sudo apt-get install -f might work ,but i am quite eager to get the cause of this error before trying it .

enter image description here

Any help would be appreciated.

share|improve this question

closed as too localized by Jorge Castro, Eric Carvalho, Thomas W., Uri Herrera, Basharat Sialvi May 26 '13 at 2:11

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

Google has fixed this issue in their release of Chrome today. Just download and install it. –  user160945 May 22 '13 at 17:40

8 Answers 8

up vote 26 down vote accepted

This is a bug in Google Chrome, from the release notes:

The official Google Chrome installer is built against libudev0 instead of the libudev1 available in Ubuntu 13.04. This should be fixed with Chrome 28 which is still in testing. We recommend that you install the open source chromium-browser from the Ubuntu Software Center until Google releases the fix for this issue. (Google: #226002)

share|improve this answer
Always read Release notes first , lesson learnt , thanks @jorge :) –  atenz Apr 26 '13 at 17:21
I don't think there is any difference between chromium-browser and google chrome on ubuntu as ubuntu update manager takes care of updates. so ubuntu users can just install chromium-browser –  balki May 4 '13 at 5:37
They are different: askubuntu.com/questions/6253/… –  Jorge Castro May 4 '13 at 13:43
Fixed in Chrome beta –  phunehehe May 18 '13 at 13:33
This is now fixed in Chrome stable. –  Mark Embling May 25 '13 at 7:29

If you use Ubuntu 13.04 32-bit, download this file:

libudev0 for 32bit

If you use Ubuntu 13.04 64-bit, download this file:

libudev0 para 64bit

share|improve this answer
Thank you, this worked! –  Ben Lee Apr 27 '13 at 3:27
Please note that Ubuntu 13.04 doesn't include libudev0 for a reason (my guess: libudev1 is newer and better so libudev0 is going away). This seems to be a working workaround, but I wouldn't recommend it. –  phunehehe Apr 27 '13 at 11:14

This is what you have to do for installing google chrome on ubuntu 13.04:

for 32 bit systems:

$ wget -c www.mirrorservice.org/sites/archive.ubuntu.com/ubuntu//pool/main/u/udev/libudev0_175-0ubuntu13_i386.deb

for 64 bit systems:

$ wget -c www.mirrorservice.org/sites/archive.ubuntu.com/ubuntu//pool/main/u/udev/libudev0_175-0ubuntu13_amd64.deb

Next, download chrome from here: https://www.google.com/intl/en/chrome/browser/

$ sudo dpkg -i libudev0*.deb
$ sudo dpkg -i ~/Downloads/google-chrome*.deb
$ sudo apt-get -f install
share|improve this answer

I had the same problem. The thing is when you try to install Chrome (the stable version) it shows a dependency issue. You have to install the libudev0 library and then the installation should work.

You can find the fix here: http://www.webupd8.org/2013/04/fix-google-chrome-cant-be-installed-in.html

share|improve this answer

You can install google-chrome-unstable till the fix is released.

share|improve this answer
Would try , thanks. –  atenz May 3 '13 at 17:16

If you have a 32 bit version of ubuntu:

wget -c http://www.mirrorservice.org/sites/archive.ubuntu.com/ubuntu//pool/main/u/udev/libudev0_175-0ubuntu13_i386.deb
dpkg -i libudev0_175-0ubuntu13_i386.deb

Else for 64 bit:

wget -c http://www.mirrorservice.org/sites/archive.ubuntu.com/ubuntu//pool/main/u/udev/libudev0_175-0ubuntu13_amd64.deb
dpkg -i libudev0_175-0ubuntu13_amd64.deb

And reinstall chrome from the downloaded deb :)

share|improve this answer
apt-get install libcurl3

This helped me.

share|improve this answer
The missing dependency is libudev0, not libcurl3. –  Eric Carvalho May 11 '13 at 13:35

Here's how you can install Google's Chrome browser to your Ubuntu 13.04 system:

  1. Open a terminal window.

  2. Type in the following commands then hit Enter after each for the 32 bit version of Chrome.

    wget -O libudev0_175-i386_NoobsLab.com.deb http://goo.gl/8hrxx
    sudo dpkg -i libudev0_175-i386_NoobsLab.com.deb
    sudo apt-get install libgconf2-4 libxss1
    wget -O g-chrome-NoobsLab32.deb https://dl.google.com/linux/direct/google-chrome-stable_current_i386.deb
    sudo dpkg -i g-chrome-NoobsLab32.deb && rm g-chrome-NoobsLab32.deb

For more, see the original article at the link below.

Install Google Chrome in Ubuntu 13.04 Raring/Ubuntu 12.10 Quantal Quetzal/Ubuntu 12.04 Precise/Ubuntu 11.10/Linux Mint

share|improve this answer
Sory I'm running amd64 not 32bit –  peach Apr 26 '13 at 20:55

protected by Community May 22 '13 at 18:43

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.