Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an issue with Ubuntu since Quantal, Raring is concerned too. After the Install I can't boot to the system. I have no Windows on my PC, I just have Ubuntu on both partitions : One as main system and the second for testing. Precise was the version I could install and be able to boot after. Grub says : Reboot and insert a proper boot device ... I tried all I could find but still have the same issue. The only Option I know will work now is installing Precise, but I DON'T WANT THAT ( just to be clear ).

I tried BootRepair without any success. Here is the logfile created by BootRepair after some attempt.

After Install, trying nothing, Bootrepair produced this log : http://paste.ubuntu.com/5604883/

After Reinstalling, separating the boot partition :http://paste.ubuntu.com/5604927/

After letting Bootrepair Install grub-legacy instead of Grub2 which reported one error: http://paste.ubuntu.com/5605140/

I can't use my computer at all without the Live USB.

Worth mentioning too, my Computer is not UEFI compatible, so no uefi here.

Update : Today I tried grub-emu from the live USB, I did as folow :

sudo mount /dev/sda1 /mnt
sudo mount --bind /dev /mnt/dev
grub-emu -d /mnt/boot/grub

and I can see that grub-emu sees my grub Infos. But when booting from the HDD I still get the same issue.

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.