Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

HDMI output used to work fine on my Samsung NP300E5C laptop in Ubuntu 12.04. However, I did a reinstall with the new 13.04 release (64 bit), and now I don't see the HDMI output as a choice in the Sound Settings.

The aplay -l command returns the following:

**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC269VC Analog [ALC269VC Analog]
      Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

This means that the device is found, but can't be used, as can be seen when I input speaker-test -c 2 -r 48000 -D hw:0,3:

speaker-test 1.0.25

Playback device is hw:0,3
Stream parameters are 48000Hz, S16_LE, 2 channels
Using 16 octaves of pink noise
Playback open error: -19,No such device

Also, alsamixer doesn't show sliders related to the HDMI output. What do?

share|improve this question

4 Answers 4

To my knowledge there is a bug in the 3.9.0-19-generic kernel that causes this, you can use the mainline kernel till it is fixed, here is a easy installer for it https://github.com/GM-Script-Writer-62850/Ubuntu-Mainline-Kernel-Updater

share|improve this answer
    
Thank you SO MUCH... I've spent 2 hours trying to fix this with no success... After finding this question and reading your answer IT WORKED. –  Paul Apr 26 '13 at 21:12

Yes, it's a kernel bug introduced around mid-April (by ubuntu I think). Generic kernels don't have the problem. Nor do ubuntu kernels before mid April.

subscribe to this bug report to keep up to date on it: https://bugs.launchpad.net/bugs/1169761

share|improve this answer
    
Thanks to both answerers. Now we can see the latest episode of the most popular soap opera of my country with my girlfriend without me having to boot into w*ndows, accompanied by a lot swearing on my part. I'll keep following the bug report, hope the ubuntu kernels catch up! –  jüri Apr 26 '13 at 22:15

After not having success with adding the alsa-daily packages or options to alsa-base.conf, I found if I added radeon.audio=1 to my boot options I was able to get audio to work. Still need to perform more testing to see how stable it is.

https://bbs.archlinux.org/viewtopic.php?id=124130

share|improve this answer
sudo gedit /etc/default/grub

replace

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

with

GRUB_CMDLINE_LINUX_DEFAULT="i915.disable_power_well=0 quiet splash"

from: https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/1256655

share|improve this answer
    
Better to run sudo -H gedit /etc/default/grub to prevent hassles with user-specific gedit config files. –  Eliah Kagan Sep 13 at 18:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.