Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

tl;dr Is there a generic guide to set up GNOME background services to work with Awesome WM on any Ubuntu?

The official guide doesn't seem to have been updated since Ubuntu 11.10. Another guide is slightly more up to date, but after upgrading to 12.10:

  1. GNOME panels on the top and bottom of the first monitor. They shouldn't be there.
  2. Awesome WM background image.
  3. Awesome panels on the second monitor.
  4. Awesome controls work (Mod4+number to go to tag, etc.).

After upgrading to 13.04 today it's even worse:

  1. GNOME panels on the top and bottom of the first monitor. Still shouldn't be there.
  2. No panels on the second monitor.
  3. Awesome WM background image.
  4. feh error message when logging in even though it is installed. Sorry, can't copy it here since I can't reproduce (see below).
  5. Windows are placed at X=0 and Y=something like -10 (the window title bars are about 90% offscreen). This means I can't access the menu in the top panel without closing all open applications (since they can't be moved by dragging with either Mod4 or Meta held down).
  6. Some GNOME keyboard shortcuts work (Ctrl+Meta+Del, Ctrl+Meta+t), but not others (Meta+F1).
  7. No Awesome keyboard or mouse controls work (Mod4+number, Mod4+Enter, Mod4+mouse drag).

Points 3 and 4 only happened the first time after rebooting into 13.04; on the second login I get the Ubuntu background image and no feh error message.

The command I cobbled together to setup "Awesome GNOME" based on the guide (reformatted for readability):

sudo sh -c '
apt-get install awesome awesome-extra gnome-session-fallback notification-daemon && \
printf "%s\n" "[Desktop Entry]" "Version=1.0" "Type=Application" "Name=awesome" "TryExec=awesome" "Exec=awesome" | tee /usr/share/applications/awesome.desktop && \
printf "%s\n" "[Desktop Entry]" "Name=Gnome with Awesome" "Comment=Gnome with Awesome as window manager" "TryExec=gnome-session" "Exec=gnome-session --session=awesome" "Type=Application" | tee /usr/share/xsessions/gnome-awesome.desktop && \
printf "%s\n" "[GNOME Session]" "Name=Awesome" "RequiredComponents=gnome-panel;gnome-settings-daemon;" "RequiredProviders=windowmanager;notifications;" "DefaultProvider-windowmanager=awesome" "DefaultProvider-notifications=notification-daemon" | tee /usr/share/gnome-session/sessions/awesome.session'

@RolandSommer's answer fixed most of the issues. In the meantime I worked around a crash by commenting out all awful.util.spawn entries.

share|improve this question
add comment

2 Answers 2

up vote 5 down vote accepted
+50

You have gnome-panel as requirement in your session description, so you are actually requesting the panels to be there.

Besides the gnome-panel-requirements I use the exact same setup within Ubuntu 13.04 and it works perfect.

Change

RequiredComponents=gnome-panel;gnome-settings-daemon;

to

RequiredComponents=gnome-settings-daemon;

and you are set.

share|improve this answer
    
Fixes all the problems except the feh error messages, which I can totally live with. –  l0b0 May 16 '13 at 20:15
add comment

About feh error message: Try to change theme.wallpaper_cmd in your theme.lua to { "" }. Gnome services will set wallpaper for you without any help (at least it works in 12.10)

share|improve this answer
    
Actually, i just found better solution to solve wallpaper problem: you need to disable nautilus desktop handling, so it will stop conflicting with feh on first startup askubuntu.com/questions/84847/… –  dlussky May 25 '13 at 23:56
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.