Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed eclipse 4.2 java on Ubuntu 12.04 x86_64 and it just crashes everytime it opens the auto completion context menu. It crashes without any error message and just closes the eclipse window. Interestingly, it also crashes when I click on of the menu points in Edit->Content Assist AND it crashes when I click in the Window->Preferences on the menu point General->Web Browser. (I experienced that because I wanted to switch off auto completion, but I couldn't find it.)

Does anybody have a clue what's wrong? I can provide any information you need, just let me know. I can also perform steps that might seem promising to you and report the results.

Some information that might be interesting to you:

I have tried with different versions of java JDK, e.g. openjdk-6-jdk, openjdk-7-jdk, oracle-6-jdk, oracle-7-jdk, and different versions of eclipse, e.g. eclipse 3.7 (Indigo) and eclipse 4.2 (Juno). Nothing worked out, but maybe I did it wrong because I had to install oracle-jdk's manually.

$ java -version
java version "1.7.0_15"
OpenJDK Runtime Environment (IcedTea7 2.3.7) (7u15-2.3.7-0ubuntu1~12.04.1)
OpenJDK 64-Bit Server VM (build 23.7-b01, mixed mode)

$ javac -version
javac 1.7.0_15
share|improve this question
    
On the web browser part it probably doesn't have the firefox mini-browser/library whatever it embeds (I've seen that before). The other ones, no idea. –  hbdgaf Apr 26 '13 at 12:41

1 Answer 1

There could be a bug that has been fixed. You can try and run an update on Eclipse: Click on the menu Help, then on Check for updates.

You will then wait a bit and if there are updates, a list of packages will come up. Just follow the instructions on the screen.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.