Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have read a lot of posts about this, mainly it is people with ATI cards or people that havnt got the option to choose HDMI audio. But it just ain't my problem, afaik.

I have installed my Graphics card, and hooked up my old labtop to the TV as a media center, videofeed is going through nicely. But the sound is lacking, even though the HDMI output is selected, then it stills outputs the sound through the labtop.
I have got a nvidia 9500M(as far as i remember) updated the drivers like this

At the bottom you will see an image with my option to select HDMI, but no mode or a like is available but the option is there.

Hopes someone can help me. Thanks

EDIT 1: Okay so have tried what was written, running alsamixer (really not sure what I can do within it though there is nothing directly mentioned as HDMI, could not turn up volume for S/PDIF it was locked on 00, screenshot at the bottom.)
Also I installed pavucontrol, and tried it, did nothing.

What I find really weird is that when i switch from speakers to HDMI nothing happens, I still hear sound through the speakers, but if I change to S/PDIF then sound stops, also if switched to HDMI again. Until it has been switched back to speakers.

Image 1(option to choose HDMI):
image 1

Image 2(alsamixer):

Image2 of alsamixer

share|improve this question
    
Have you tried running alsamixer, to ensure that the HDMI on the video card isn't muted? I also had to run pavucontrol and select HDMI as the output device, but I'm using Xubuntu, not regular Ubuntu, so I don't know if the same applies... –  Ash Apr 26 '13 at 13:30
    
@Ash You can see result and maybe give some more advice? –  Anders Metnik May 2 '13 at 17:44
    
In alsamixer, press F6 and see if there's another device on the list other than the one above -- that may be your GPU (the default one is normally the onboard, but I'm not sure, since it says nVidia above...) –  Ash May 2 '13 at 22:51

1 Answer 1

I recall having a similar problem some time ago. I installed Pulseaudio Volume Controller and used that to select the HDMI output under the configuration tab. Do

sudo apt-get install pulseaudio

I'm not sure this will work but it may be worth a try!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.