Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an Acer Aspire M laptop, which comes preinstalled with Windows 8, so it has this new UEFI stuff.

To get the Ubuntu LiveDVD running, I had to disable the UEFI completely and switch to legacy BIOS mode. But after that I couldn't boot Win8 anymore.

In many questions here I read that ubuntu 12.04.2 works with EFI but not with Secure Boot. But since I can't disable just one, I'm pretty much in a dead end.

Also it seems that UEFI boots faster than legacy BIOS, so it would be nice if I could keep all this for both Windows and Ubuntu :\

share|improve this question
add comment

5 Answers

up vote 1 down vote accepted

Dual Boot Windows 8 and Ubuntu 13.04 on Acer TravelMate

I was at the same dead end: I could not disable secure boot in the UEFI-mode in the BIOS of an Acer Travelmate P253-E with pre-installed Windows 8. The Secure Boot option was just gray and could not be reached with up/down keys. With secure boot enabled, the attempt to install Ubuntu 13.04 from LiveCD ended with the message: "DVDRAM has been blocked by the current security policy"and I could not boot the LiveCD.

I tried a lot (set supervisor password in BIOS...) but in the end I guess the Windows 8 factory reset did it (described here: http://www.pcadvisor.co.uk/how-to/windows/3443121/how-refresh-reset-windows-8/?pn=2). I did the "Clean drive fully" option, it took a whole night to run! After that I could change the Security Boot to "Disable" in the Boot Section of the UEFI-BIOS.

I installed Ubuntu 13.04 64bit with a LiveCD and chose the windows boot partition "fat32 EFI system partition boot" as "device for boot loader installation".

After installation, the Notebook booted directly to Windows 8. No chance to boot Ubuntu...

I booted Ubuntu 13.04 via my Ubuntu13.04 LiveCD and installed and run the Boot-Repair ("recommended repair") as described here: https://help.ubuntu.com/community/Boot-Repair

And this it is: Now booting the Notebook, gives me a screen on which I can choose to boot Ubuntu 13.04 or Win 8. With Ubuntu as default system, of course! :)

Hope I could help someone... Cheers!!

share|improve this answer
    
Windows 8 factory reset... crazy! I gave up and installed win8 and ubuntu13.04 in legacy BIOS mode. –  K.. Jul 5 '13 at 14:02
add comment

Yes I found one answer that worked for me on my ACER. You have to set a bios password in you bios menus then you can disable the secure boot and keep uefi... Then you have to run boot repair and follow the instructions....

share|improve this answer
add comment

It's usually possible to disable Secure Boot without disabling EFI support; however, the user interfaces in EFIs vary greatly from one system to another, so I can't provide step-by-step instructions for doing this. I recommend you peruse your firmware settings to find the relevant options and play with them.

Also, it was my understanding that 12.04.2 did support Secure Boot. 12.10 definitely does, and I assume that the new 13.04 does. Thus, you should be able to get Ubuntu installed with Secure Boot active. Even if 12.04.2 doesn't actually include Secure Boot support, trying 13.04 might be worthwhile. Admittedly it's not an LTS version, but given how new Secure Boot is and how quickly things are changing in this arena, giving up LTS may be the price you have to pay -- at least, to do it relatively easily.

If all else fails, you should be able to get it to work by creating your own Secure Boot medium. This is not an easy task, though. My Web page on Secure Boot covers the topic in moderate detail. In brief, you'd need to prepare a medium (a modified Ubuntu installer or a separate boot medium) that includes a pre-signed version of shim.efi or PreBootloader.efi and that launches a boot loader (ELILO, GRUB, or rEFInd) that in turn launches the Ubuntu installer's kernel and initrd file. You'd probably need to enroll keys or hashes for the boot loader and perhaps the kernel and initrd file to get this all working, too. This is not a task for a newbie, though; to get this to work, you'll need to be comfortable with boot loader/manager configuration files, kernel options, and so on.

share|improve this answer
    
Thank you! Ok I got a new win8 installation going and left 30GB for Ubuntu. I will try to install 13.04 and call back :) –  K.. Apr 26 '13 at 18:52
add comment
share|improve this answer
    
yeah, probably its because of the fast boot of win8... wich also works with legacy. I switched to legacy and installed win8 like this. –  K.. Apr 27 '13 at 12:44
add comment

it says on a few websites to delete efi folder and then the cms mode will work but you need to re-install from either flash drive or windows disk

while windows is booting up press 0 key to go into recovery manager type these commands

diskpart
list disk
select disk 0
clean
exit
exit

This will wipe your hard drive clean no go back into the bios and you should see uefi and secure boot enabled, disable secure boot. now select cms and it will ask you to boot from disk, follow the on screen instructions to install windows.

share|improve this answer
    
Could you maybe add the links to the websites you're referring to in order to improve your answer? So that OP is able to look at the source info –  Daniel Mar 10 at 2:13
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.