Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've upgraded to Raring last night. The upgrade itself went okay, no errors. But when I rebooted the computer afterwards and logged in to my Unity session, all I could see was the Desktop background (together with Desktop icons), and no Unity interface. The Super button shortcut wasn't showing the Dash, there was no top panel etc. Please see the screenshot.

No Unity after upgrading to 13.04

As a hint, I'm suspecting it's got something to do with my switchable graphics. I'm running Ubuntu on Acer Aspire AS5830TG with nVidia GT540M and an Intel integrated card. In 12.10 I was using Bumblebee to manage the graphic card switching. During the upgrade I saw something related to nvidia had to be uninstalled, but didn't pay much attention to it. I can't be sure if it has anything to do with my problem though.

What could possibly go wrong?

share|improve this question
    
I got the same problem, also I'm using NVidia card, it must be something with it. –  Alen Apr 26 '13 at 7:52
    
I have the same problem with an AMD card. –  eagleflo Apr 26 '13 at 8:35
    
Right, I think I've messed up something, trying to install newer nVidia drivers. Now my both graphic cards are detected and used properly, but my monitor isn't detected and the resolution can't be changed from 640x480. Although nvidia-settings package is installed, I don't see the application in the Apps menu. Also, if I log into the Guest account, Unity interface exists, but on my regular account I'm still having the same problem - no Unity. –  Томица Кораћ Apr 27 '13 at 10:06
    
And another update. I was able to partially fix the resolution by deleting /etc/X11/xorg.conf and renaming /etc/X11/xorg.conf.failsafe to /etc/X11/xorg.conf . This fixed resolution in Gnome session and Unity session for my account (Unity still not running though), but not for Guest session, which is running Unity, but with screen resolution 640x480. –  Томица Кораћ Apr 27 '13 at 10:30
    
And yet another update. After rebooting even the Guest session has the resolution fixed. But in my main account still no Unity. And for some reason my sound's gone :( –  Томица Кораћ Apr 27 '13 at 10:44

10 Answers 10

up vote 5 down vote accepted

Resetting Compiz as indicated by arkx worked for me. However, I had to update the Nvidia drivers first, as detailed here: http://falkvinge.net/2013/02/15/how-to-install-nvidia-drivers-in-ubuntu-12-10-quantal/

Unity seems to be working OK now. Thanks!

share|improve this answer
1  
Please provide some details - summarize. The link is fine but we have no control over other sites. –  Warren Hill Apr 27 '13 at 16:23
    
I guess something like that must have worked for me. It's back to normal now, although I hate to say I'm not aware what exactly was it that I did that fixed it. I'll accept this answer, but for the rest of you guys, I'm still not 100% sure that it will work for everyone. –  Томица Кораћ Apr 27 '13 at 17:01
    
broken link, please update. –  elgalu Jan 16 at 21:49

This worked for me:

  1. Press Ctrl+Alt+T to open a terminal window.
  2. At the terminal prompt, type ccsm. If the CompizConfig Settings Manager window appears, skip to step 5. If not, continue with step 3.
  3. Type sudo apt-get install compizconfig-settings-manager. Type your password when prompted.
  4. At the next terminal prompt, type ccsm.
  5. In CompizConfig Settings Manager, select the check box for the OpenGL plugin if it isn't already selected.
  6. Click the Ubuntu Unity Plugin item.
  7. Select the Enable Ubuntu Unity Plugin check box, if it isn't already selected. If it is already selected then uncheck this and again select it.
  8. Exit from the CompizConfig Settings Manager.
  9. Press Ctrl+Alt+Delete. When asked, confirm that you want to log out.
  10. I did a cold reboot at this point. I'm not sure it's necessary, but I'm a bit paranoid.

After this, Unity came up as it's supposed to for me.

I have a 64-bit AMD Phenom CPU and an nVidia GPU; I'm running 64-bit Ubuntu with the nvidia-current driver set, and I've just upgraded to 13.04 (at which point Unity disappeared).

share|improve this answer
1  
Wow! Thanks. This worked for me (13.04). I hope there's a way to do this in terminal. That be more convenient. I've lost some Unity features though like "aero snap." I don't know how to fix that. –  kelvinilla Apr 28 '13 at 9:01
    
I've lost some Unity features though like "aero snap." Scratch that. I typed "unity --replace", the panels disappeared again, rebooted. –  kelvinilla Apr 28 '13 at 9:12
1  
Excellent. A small detail though. There is no check box next to Ubuntu Unity Plugin. I had to click on the icon and on the left there was a checkbox to click. I then had a dialog asking me to activate another plugin required for Unity plugin and two dialogs to resolve keyboards shortcuts conflicts between unity and gnome. Once I validated the last dialog, the desktop was displayed. I didn't had to logout. Thank you very much. This site is worth a million working hours ! –  chmike Aug 22 '13 at 8:41
    
I'm at the point after ccsm and it's taking a hell of a long time at "Loading icons..." Is this normal? –  crclayton Aug 4 at 20:51

I fixed this issue by opening a terminal with Ctrl + Alt + T, resetting compiz with dconf reset -f /org/compiz/ and logging out with gnome-session-quit.

When I logged back in the interface was there again.

share|improve this answer
    
Unfortunately this didn't work for me. –  Томица Кораћ Apr 26 '13 at 8:44
    
Did you take a look at ~/.xsession-errors? There might be some clues there as to what went wrong. –  eagleflo Apr 26 '13 at 8:51
    
my ~./xsession-errors is some 1000 lines long. and yes, I do have a whole bunch of reports there, one of which says: 'compiz (core) - Info: Unity is not supported by your hardware. Enabling software rendering instead (slow).' But I can't seem to find anything in there to help me fix it... –  Томица Кораћ Apr 26 '13 at 8:57
    
That sounds like a graphics driver issue. Perhaps reinstalling Nvidia drivers would help? –  eagleflo Apr 26 '13 at 9:41
    
I have a Intel/AMD hybrid and using the x.org driver and this solution worked for me. –  DrA7 Apr 26 '13 at 20:02

I ended up installing gnome-panel just to get an interface so I could launch applications.

If you launch the Compiz settings manager and reset the configuration to defaults, it should launch your interface again after you log out / in.

You can safely remove gnome-panel after doing this; I launched it from a command line to get to the compiz settings icon.

Hope this helps!

share|improve this answer
    
Nate thanks a lot for the help. I already have gnome-panel, so atm it's not a big deal for me, I get the work done. Unfortunately, I've already reset the Compiz settings, as you and @arkx mentioned, but it didn't help me. I'm still clueless, although I really suspect the graphic drivers. –  Томица Кораћ Apr 27 '13 at 8:19

I had this problem running an Ubuntu virtual machine on VirtualBox after upgrading from VirtualBox 4.1 to 4.3. I had to reinstall Guest Additions from a terminal. After that, everything worked as expected.

share|improve this answer

This also happened to me and switching to gnome fixed my problem. To get gnome open the terminal (CtrlAltt)and run the following command:

sudo apt-get install gnome-session-fallback

After it installs just logout and hit the icon next to your name, then select gnome fallback.

share|improve this answer
    
Actually, installing another desktop environment is not an answer to my question. But thanks for your effort Tyler. –  Томица Кораћ Jul 17 '13 at 12:02

I tried several of previous options, and it worked for me installing: compizconfig-settings-manager, enabling unity plugin and after that i did ./compiz --replace and it started to work.

Before doing this step, I created another user, and when I logged in as that new user, unity was working. So, I understand that the problem was that while doing upgrade some config file had some obsolete settings that got updated after changing settings in compizconfig-settings-menager.

share|improve this answer

Dang I hate when this happens. Somehow everything's back to normal. I've been fiddling around with my system, installing some drivers, uninstlaling some kernels, I actually have no idea what exactly was it that I did that fixed it. I remember deleting /etc/X11/xorg.conf and renaming /etc/X11/xorg.conf.failsafe to /etc/X11/xorg.conf which fixed a few things, but not all. Now I wouldn't try to explain the rest because I'm simply not able to explain in a non-confusing way. I hope the rest of you guys with the same problem will find your way around this.

share|improve this answer

My solution was to remove all nvidia and just use intel opengl driver. Waiting for it to just work. Better batterylife anyway :)

share|improve this answer

I just uninstalled the ATI driver and reinstalled it and everything is fine.

My system features hybrid graphics and I installed driver 13.1 from AMD website for discrete card and everything was fine until I update my system and rebooted it. After I logged on the screen goes black and the Unity wont start. I do a lots of googling, and do the Unity reset but that does not fix it. Reinstalling the ATI driver fixed it in the end.

share|improve this answer

protected by Community Sep 17 '13 at 7:21

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.