Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am fairly new to Ubuntu, I have only been using it for ~2.5 months. Is there any way to fix the HDMI Audio, besides the proprietary drivers? If I need to report it as a bug where would be my best bet?

As stated in the title audio will not work via HDMI for the Radeon HD 7570. HDMI does not appear in sound settings and alsamixer does not properly recognize the card

I have tried all of the suggestions I've come across:

editing /etc/default/grub with "radeon.audio=1" (then update grub)
updating alsa-mixer
xorg-edgers ppa
mainline kernels (v3.9)
etc...
I forgot the rest, it's been a tough two months of trying to figure this out, sorry... :(

Running ubuntu 13.04,
Video card: AMD Radeon HD 7570,
Computer: Dell XPS 8500
HDMI also does not work on ubuntu 12.04 or 12.10 (catalyst does have hdmi audio but looks terrible).

AMD Catalyst (fglrx) driver does work for audio but the video is subpar at best, it's hard to read any text because of the blockyness, and runs awkwardly slow for some more graphics intensive programs. The Xorg servers are the exact opposite (audio doesn't work but video looks great, text is easy to read, and runs the more graphics intensive stuff better).

It might be worth noting that lspci erroneously displays "Radeon HD 6000 Series" for "Audio" but correctly identifies it as HD 7570 for video. Also alsamixer is showing "ATI R6xx HDMI" for card 1

I've included the lspci, aplay -L, and the info alsamixer displays below. If there is anything else that would help, please let me know.

I would appreciate any help I can get.

Lspci :

00:00.0 Host bridge: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor PCI Express Root Port (rev 09)
00:14.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller (rev 04)
00:16.0 Communication controller: Intel Corporation 7 Series/C210 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 1 (rev c4)
00:1c.3 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 4 (rev c4)
00:1d.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation H77 Express Chipset LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 7 Series/C210 Series Chipset Family 6-port SATA Controller [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 7 Series/C210 Series Chipset Family SMBus Controller (rev 04)
01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Turks PRO [Radeon HD 7570]
01:00.1 Audio device: Advanced Micro Devices [AMD] nee ATI Turks/Whistler HDMI Audio [Radeon HD 6000 Series]
02:00.0 Network controller: Atheros Communications Inc. AR9485 Wireless Network Adapter (rev 01)
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168 PCI Express Gigabit Ethernet controller (rev 07)

~ ~ ~ ~ ~ ~ ~ ~ ~ ~

aplay -L:

**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC887-VD Analog [ALC887-VD Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 1: ALC887-VD Digital [ALC887-VD Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Generic [HD-Audio Generic], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

~ ~ ~ ~ ~ ~ ~ ~ ~ ~

Alsamixer (for device 1):

Card: HD-Audio Generic                               F1:  Help
Chip: ATI R6xx HDMI                                  F2:  System information
View: F3:[Playback] F4: Capture  F5: All             F6:  Select sound card
Item: S/PDIF                                         Esc: Exit 
share|improve this question
    
I solved by updating the kernel to 3.9.0. <br/><b>blog.avirtualhome.com/linux-kernel-3-9-on-ubuntu/</b>; <br/>I have a card AMD HD 7770 GHz Edition. –  user155983 May 6 '13 at 4:15
    
Unfortunately I have my kernel updated to 3.9.0 and still no dice. I'm not sure what the issue is. I haven't been able to solve it with anything. I broke down and bought a cheap speaker system, sounds better than my TV anyways. Now my only issue is the audio jacks are different between windows and linux, guess windows is relegated to TV quality speakers, lol. –  Relsig May 8 '13 at 0:46
add comment

2 Answers

It's a known bug for about a couple of weeks. The kernel in 13.04 is buggy. Solutions are to use a newer kernel or an older kernel. Hopefully this will be fixed soon; there will be many people affected by this (like everyone using Ubuntu to drive a media PC).

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1169761

share|improve this answer
    
Unfortunately, neither upgrading to a newer (mainline) kernel nor downgrading to an older kernel solve this issue. Due to this the bug may be an additional hindrance but is otherwise unrelated to my question. HDMI audio was also not working for me on 12.10 or 12.04 so this is not specific to the 13.04 release. –  Relsig Apr 26 '13 at 13:52
add comment

This issue exists since Linux 3.0

"Due to some people having blank screens linked to the HDMI audio support in the open source Radeon driver, HDMI audio is now disabled by default. However, if you used the HDMI audio before upgrading to Linux 3.0, you'll notice your sound doesn't work anymore.

To re-enable HDMI audio, in /boot/grub/menu.lst, add this to the end of your "kernel" line: radeon.audio=1

For example, this is my first "kernel" line in my menu.lst (I left the fallback alone):

kernel /boot/vmlinuz-linux root=/dev/sda1 ro radeon.audio=1

After a reboot, your sound should be restored."

share|improve this answer
    
Source? Also, /boot/grub/menu.lst doesn't exist on my Ubuntu 13.04. –  l0b0 May 17 '13 at 11:41
    
Please re-read my original post, specifically the first line of the things I've tried: "I have tried all of the suggestions I've come across: editing /etc/default/grub with "radeon.audio=1" (then update grub) updating alsa-mixer xorg-edgers ppa mainline kernels (v3.9) etc..." –  Relsig May 19 '13 at 0:17
    
I have a Mobility Radeon HD 3650 and this, plus updating to linux 3.9.4 is what did the trick for me. It also fixed the apparently related issue in which mplayer plays movie clips to fast. –  Björn Lindqvist Jul 7 '13 at 23:29
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.