Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

TortoiseHG previously worked on 12.10, but after today's reinstall, it simply doesn't show up, not even with the thg command.

share|improve this question
    
I have the same behavior; moreover, the returned code from thg is 0, which does not help much :-/ –  piwi Apr 26 '13 at 12:08

2 Answers 2

up vote 10 down vote accepted

I managed to install it rather easily by using the tortoisehg ppa:

sudo add-apt-repository -y ppa:tortoisehg-ppa/releases
sudo apt-get update
sudo apt-get install mercurial tortoisehg

Note: @piwi's method works too.

share|improve this answer
    
thanks, I couldn't figure out why my thg showed no vital signs today.. this put the wheels back on my car –  wim May 21 '13 at 6:23

This is not a solution but rather a workaround. The version of TortoiseHG from the repository works fine.

I first installed the latest version of mercurial (otherwise thg will complain about a version mismatch for hg); I installed it in ~/opt:

hg clone --branch stable http://selenic.com/hg ~/thg/mercurial
cd ~/thg/mercurial
python setup.py install --prefix=$HOME/opt

export PATH="$HOME/opt/bin:$PATH"
export PYTHONPATH="$HOME/opt/lib/python2.7/site-packages:$PYTHONPATH"

I use bash, so I needed to remove the hash entry for mercurial:

hash -d hg

Then I made a copy of the thg repository and ran it from the repository I wanted to work from:

hg clone --branch stable http://bitbucket.org/tortoisehg/thg ~/thg/tortoisehg
cd ~/devel/myrepo
~/thg/tortoisehg/thg
share|improve this answer
    
Although this worked as expected, I found a PPA that works. See my answer. –  rebelliard Apr 26 '13 at 14:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.