Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This is what my dash currently looks like. I have no clue why the other lenses are not being shown.

Dash

$ sudo apt-get install unity-lens-friends unity-lens-files unity-lens-help unity-lens-movie unity-lens-radios 
Reading package lists... Done
Building dependency tree        
Reading state information... Done
unity-lens-files is already the newest version.
unity-lens-friends is already the newest version.
unity-lens-help is already the newest version.
unity-lens-radios is already the newest version.
unity-lens-movie is already the newest version.
0 upgraded, 0 newly installed, 0 to remove.

/usr/share/unity/lenses$ ls
contacts  files  friends  help  movie  radios  shopping

This disappearing act has happened after upgrading to 13.04 (64bit). All I did was remove Eclipse installation and installed a standalone version of it. But I highly doubt

share|improve this question
    
it's offtopic see askubuntu.com/questions/285718/… –  Avinash Raj Feb 7 at 16:11

1 Answer 1

up vote 2 down vote accepted

After install some lens all disappears, just like your.

Well, my problem was solved after removing and installing some libraries from Synaptic.

  1. If you have installed this lens please remove:

    unity-lens-shopping
    unity-scope-askubuntu
    
  2. Install this items. I do this form Synaptic, but I believe that you can install from terminal too:

    liblensfun-data (0.2.7-0ubuntu1)
    liblensfun0 (0.2.7-0ubuntu1)
    unity-scope-home (6.8.0daily13.04.23ubuntu.unity.experimental.certified-0ubuntu1)
    

Like I said, for me it's work. I don't know how is the right library to solved, I install this 3 and solved my problem.

I hope that can help up.

share|improve this answer
1  
i just completely reinstalled 13.04 and it worked :/ sorry i couldn't try your method, hopefully it works for someone else –  Akash Ramani May 2 '13 at 16:23
    
Yep, it works. For changes to take effect one must re-login. –  Danatela Feb 12 at 10:13
    
Isn't liblensfun an image processing library? I don't think it's related to dash lenses. I think the only relevant package in step 2 is unity-scope-home. –  monotasker Feb 12 at 18:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.