Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This is a new problem I'm facing in 13.04, and is not related to what worked for 12.10 or earlier.

In 12.10, I had the acpi_backlight=vendor in my grub in order to make the brightness setting work. However, this does not work on 13.04. I don't even see a brightness bar.

To change that, I tried acpi_osi= and the brightness bar appeared in the system settings. Moving it doesn't change the brightness, but using my hotkeys does.

Since Ubuntu doesn't remember the brightness settings between boots, I had a script that would adjust it during startup. Now, even that doesn't seem to work. Only my hotkeys work at the moment.

Laptop information:

  • Model: Acer Aspire E1-571
  • Processor: Intel® Core™ i3-3110M CPU @ 2.40GHz × 4
  • Graphics: Intel® Ivybridge Mobile
  • OS type: 64bits

Things I've tried

  • acpi_osi= using this makes my hotkeys work, but the brightness slider doesn't work
  • acpi_osi=Linux
  • acpi_osi='!Windows 2012'
  • acpi_osi='!Windows 2012' acpi_backlight=vendor
  • acpi_backlight=vendor
share|improve this question
Can you add what kind of laptop it is to your question? – Jorge Castro Apr 26 '13 at 22:43
@JorgeCastro: I've added my Laptop's specifications – AgilE Apr 27 '13 at 6:33

Try using acpi_osi='!Windows 2012' the same way you would use acpi_backlight=vendor that fixed it for me, another one to try is acpi_osi=Linux

share|improve this answer
Doesn't work for me on Toshiba Satellite R830. Actually using !Widnows 2012 makes matters worse. – To Do Apr 26 '13 at 21:41
This didn't work. Adding '!Windows 2012' makes my hotkeys stop working. – AgilE Apr 27 '13 at 6:37
have you tried this one acpi_backlight=vendor acpi_osi= – GM-Script-Writer-62850 Apr 27 '13 at 15:10

As a temporary(?) solution I boot Ubuntu 13.04 64bit with my latest Ubunt 12.10 64bit kernel ( so I boot with 3.5.0-27-generic, not with the newest 3.8.0-19-generic)

I've also kept the old /etc/default/grub file that I used in 12.10 (where I had to add acpi_backlight=vendor to make my brightness keys Fn-leftt and Fn-right function)

share|improve this answer
If it works on the 3.5 and not the 3.8 and you needed acpi_backlight=vendor try acpi_backlight=vendor acpi_osi='!Windows 2012' with the 3.8 kernel – GM-Script-Writer-62850 Apr 29 '13 at 1:24
acpi_osi ='!Windows 2012' (that is Windows 8) works only if you have a BIOS that knows what do with that information. My BIOS goes until 'Windows 2009', so it will not be able to handle that information. – user85164 Apr 29 '13 at 4:58

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.