Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm not able to switch to Seamless Mode in VirtualBox with Ubuntu 10.04 or 9.10 as guest OS's. I have tried the seamless mode with XP as guest OS, and it works absolutely fine. The host OS is Windows 7.

I have in-built Via/S3G Unichrome Pro IGP graphics, and I have allocated 30 MB out of 64 MB of graphics memory. I've also 1.5 GB of RAM.

I also tried installing Guest Additions but it still didn't work. VirtualBox version is 4.0.4r70112. The Host+L does not lead to seamless mode. i.e. under the Machine menu in Virtual box window "Seamless mode" is disabled (comes in grey color). How can I get the seamless mode to work? Please help!

share|improve this question
    
I have the same problem. In one of my virtual boxes it works, but in the other not. Both have Guest additions installed. –  Johan Karlsson Sep 2 at 12:52

5 Answers 5

For seamless mode (Host+L) Virtual Box Guest Additions of the same program version need to be installed in the guest OS.

How to install Guest Additions see also this answer. In some cases you will simply need to reinstall the Guest Additions if they don't run the way they should.

share|improve this answer
1  
Takkat i have installed Virtual box and guest additions of same version. But what problem i have is the Host+L does not lead to seamless mode. –  jsbisht Mar 2 '11 at 4:25
    
If I got you right then you are able to select seamless but you can't move the window of a guest Ubuntu program to the desktop of your host? –  Takkat Mar 2 '11 at 8:52
    
i m not able to select seamless mode. –  jsbisht Mar 2 '11 at 17:30
1  
This usually indicates that Guest Additions are not installed. Try again and don't forget to reboot the guest OS to take effect. –  Takkat Mar 2 '11 at 17:37
    
i have tried all that but still the same problem. Anyways thanks. –  jsbisht Mar 3 '11 at 10:13

May be you forgot installing the guest additions in the GUEST. For doing so, click in the menu "Devices" in the GUEST window, and choose "install guest additions"

share|improve this answer

Install Guest Addtions from Synaptic.

share|improve this answer
    
how to look for guest additions in synaptic. is there a package name for it. –  jsbisht Mar 1 '11 at 17:58
    
Go to Synaptic, after it loads, you'll see a search box in the top right corner. Simply type guest additions there and press Enter. –  Oxwivi Mar 1 '11 at 18:14
    
@jaggib, did you try install Guest Additions from Synaptic yet? –  Oxwivi May 31 '11 at 15:55
    
This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post. –  RolandiXor Sep 28 '12 at 22:00
    
@RolandTaylor I think the idea here is to install Guest Additions with the guest Ubuntu system's package manager, rather than the (possibly different) version installed through VirtualBox itself (which is what it sounds like the OP did). So, this is an answer to the question. I'm not sure if it's a right answer, but it is an answer. –  Eliah Kagan Oct 1 '12 at 19:05

Try by clicking and holding Right Ctrl key and then clicking the L key.

share|improve this answer

I'm running windows8.1 guest on ubuntu host and seamlesss mode don't get enabled until user session is started in windows, maybe a few seconds after login.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.