Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I need to manually do 'ps and kill -9' to kill it.

share|improve this question

3 Answers 3

up vote 4 down vote accepted

Alternatively if you prefer not having everything listed under Startup Application, disable Ubuntu One at login:

echo "Hidden=true" | sudo tee -a /etc/xdg/autostart/ubuntuone-launch.desktop

Show Ubuntu One in Startup Applications:

sudo sed -i "s/NoDisplay=true/NoDisplay=false/g" /etc/xdg/autostart/ubuntuone-launch.desktop

You can use the second command I posted to replace MorganSBailey's command and not effect all startup entries

share|improve this answer
    
One should not edit these files in their lcoation in /etc. If you wish to manage how they are used, then the autostart .desktop files you wish to change should first be copied into ~/.config/autostart/ and edited there. –  dobey Apr 26 '13 at 19:31

If you open the Ubuntu One control panel application from the launcher or dash, and go to the Settings tab, you can disable the Connect automatically when computer starts option. This will keep it from connecting automatically on start.

If you do need to actually not run it for some reason, you should do the following:

#: mkdir -p ~/.config/autostart
#: cp /etc/xdg/autostart/ubuntuone-lauch.desktop ~/.config/autostart/
#: echo "X-GNOME-Autostart-enabled=false" >> ~/.config/autostart/ubuntuone-launch.desktop

This will disable the launcher program from running on start. However, it will not disable other applications requesting that ubuntuone-syncdaemon be launched, via DBus, so that they can communicate with it. If any applications do request connection to it, then DBus will automatically launch it.

share|improve this answer

Open a terminal and type:

sudo sed -i "s/NoDisplay=true/NoDisplay=false/g" /etc/xdg/autostart/*.desktop` 

That will unhide the applications hidden by default in Startup Applications. Now go to Startup Applications, find the Ubuntu One entry and untick it. That should do it.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.