Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have upgraded to Ubuntu 13.04 and I cannot use Unity. I have tried the proprietary driver, both from the official sources and from AMD's website. I have also tried using the open source driver, and under no configuration does Unity start. Xubuntu and Lubuntu configurations start correctly on the same setup. This problem only existed in 12.10 after a kernel upgrade and was fixed by reinstalling the drivers. Reinstalling no longer fixes the problem.

I have also tried purging compiz and then reinstalling unity, and that did not solve the problem.

When I run


I see no errors, but it stops at:

compiz (core) - Info: Starting plugin: session

No more output appears in the terminal. I am currently using the proprietary driver that you install through the update manager (which I accessed with Xubuntu).

So my question is; where can I begin to diagnose the source of this problem, or does anybody have a solution?

share|improve this question
up vote 27 down vote accepted

The old methods of replacing unity no longer work in 13.04. Please try:

dconf reset -f /org/compiz/ 
unity --reset-icons &disown

Reboot if it doesn't work right away.

share|improve this answer
I ran the first command before and it did nothing, but after running the second command it seems to have fixed the problem after a reboot. Thank you very much. – Clintonio Apr 26 '13 at 0:03
Some people felt this question… was a duplicate of this one but this answer doesn't do a bloody thing for me. – Brenton Horne May 4 '13 at 5:53
Worked like a charm, thanks a ton!! – Pulkit609 Jul 9 '13 at 7:05
works when I run like that dconf reset -f /org/compiz/ && unity --reset-icons &disown at the second time – Claudio Santos Dec 17 '13 at 22:30

I had the same problem, but when I tried unity --reset-icons &disown I got the message unity was not properly installed. Never did I uninstall it, but reïnstalling using sudo apt-get install unity fixed this problem for me.
PS: Use Ctrl+Alt+T to open a terminal

share|improve this answer

protected by Community Jul 14 '13 at 5:00

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.