Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I upgraded Ubuntu today and everything works smooth except that Ubuntu doesn't detect any other storage devices. My / and /home partitions work fine, but my other partitions are just not detected. I wouldn't mind, except the same problem goes with USB sticks.

When I plug in a USB stick, the light goes on, but the computer detects nothing. Just to be clear, my Mouse and keyboard are connected via USB and work fine.

Any idea how to solve this issue. None of the suggestions I found on the Internet have any effect.

Thank you, Calixte

share|improve this question
1  
What's the output of lsblk? –  Yet Another User Apr 29 '13 at 4:03
    
Just to make sure I got this, this is stand-alone Ubuntu not in virtual machine, right? Run sudo fdisk -l in terminal and post the output. –  Jack Mayerz Apr 30 '13 at 6:38
    
Have you tried my answer Here –  Mitch May 2 '13 at 16:56
    
What is the output of df -h ? Is the USB device listed there? –  Jay May 5 '13 at 8:13

4 Answers 4

sudo lsusb will tell you what usb devices Linux detects. Whether a usb storage device mounts, or is detected, are separate issues. sudo lsusb -v will give verbose output, possibly more information than you want if the OS truly doesn't recognize the device.

alternatively, you could compare the lists of devices in /dev before and after plugging in the usb device. There are many ways to do it, I would probably just use ls -l /dev/* | wc -l

this will give you a number of recognized devices. Doing it before and after plugging in a device will tell you if the OS assigned the device in /dev/

another option would be to look at what is happening in dmesg when you plug in the usb device. dmesg may tell you things like how a device failed.

if the usb device you are having trouble mounting, is on the lsusb list, then you can try mounting the device. At this point it would be good to know the filesystem type. sudo fdisk -l will tell you the filesystem type, in the form of an ID. You may have to look up the ID number. lots of refferences online for that. Once you know the device listing ie: /dev/hda1 and the filesystem type you can try to mount the device manualy with the mount command.

sudo mount /dev/hda1 /home/user/Desktop/whereEver

You may have to make sure where you want to mount the device exists. If the OS recognizes the FileSystem, then mount might just work if the FS is not a native FS type, you may have to specify flags for mounting.

Post back your output from dmesg (not all of it, only from around when the USB device is plugged in),and sudo lsusb

You may find this helpful if trying to determine device type:

http://www.cyberciti.biz/faq/understanding-unix-linux-bsd-device-files/

I am writing this assuming all your unrecognized devices are block type devices. There are many ways to aproach this type of problem, and many possible solutions. More specific information is needed to provide a solution.

There are also many GUI appliactions that can do the same thing. You might try looking for the plugged in hardware in the "Disk Utility"

share|improve this answer
1  
why use dmesg instead of fdisk? because using fdisk assumes your hardware is working. If your hardware fails, fdisk wont tell you. but dmesg will. –  j0h May 4 '13 at 1:10

Solution 1: Try the Disks program (if you run Ubuntu with a GUI).

(check that the gnome-disk-utility package is installed) (make sure that udisk2 package is installed)

Hit SUPERA to open the Application Lens and type Disks in the Search Applications field.

(SUPER is probably the key with the Windows icon.)

In Disks you can play with the automount options.

For example:

Disks Program

You have to click on the little icon with the two gears and choose 'Edit Mount Options'.

Mount Options

Solution 2: Using the CLI (for a headless installation)

Step 1. Check the blockdevices and the file systems that are assigned to those block devices.

lsblk

lsblk

Here you see the blokdevice sdb with partition /sdb1. But it's not mounted. There's no file assigned to it.

Step 2. What kind of device is sdb?

sudo lshw 

or

sudo lshw | less

lshw

So the USB stick - the block device /sdb - has the logical name /dev/sdb. And the FAT32 filesystem on that stick has the logical name /dev/sdb1.

Step 3. Mounting the USB-stick

We will mount /dev/sdb1 to /media/usbstick

sudo mkdir /media/usbstick

sudo mount -t vfat /dev/sdb1 /media/usbstick 

Read the manpage of mount for other options.

Step 4. Did it work?

lsblk

lsblk 2

Yes, we can see that the filesystem on the USB stick is mounted to /media/usbstick

Addendum : if there are no logical names like /dev/sdb, you should first create them. See this information about setting up and controling loop devices with the losetup command

share|improve this answer
    
I like this post a whole lot actually, lsblk looks like a great program. Too bad it doesnt come with ubuntu –  j0h May 7 '13 at 13:05
    
lsblk is in the util-linux package (at least in 12.04.2 LTS) –  user85164 May 7 '13 at 22:40

You only mention one storage device type - usb stick. Whenever usb devices don't mount correctly check that you don't have package called usbmount installed. If it is, remove it and life should be back to normal after that (you might need to restart).

share|improve this answer
    
Nice program. When I run it together with udisks2 and plug-in my USB stick it complains that it's already mounted :-) –  user85164 May 5 '13 at 9:04
    
I once had it in my system and usb sticks were (if at all) mounted as root and so I could not write to them. Took quite a while to figure this one out. –  Tanel Mae May 5 '13 at 9:18

Manually Mount a USB Drive

A USB storage device plugged into the system usually mounts automatically, but if for some reasons it doesn't automount, it's possible to manually mount it with these steps.

  1. Press Ctrl+Alt+T to run Terminal.
  2. Enter sudo mkdir /media/usb to create a mount point called usb.
  3. Enter sudo fdisk -l to look for the USB drive already plugged in, let's say the drive you want to mount is /dev/sdb1.
  4. To mount a USB drive formatted with FAT16 or FAT32 system, enter:

    sudo mount -t vfat /dev/sdb1 /media/usb -o uid=1000,gid=100,utf8,dmask=027,fmask=137
    

    OR, To mount a USB drive formatted with NTFS system, enter:

    sudo mount -t ntfs-3g /dev/sdb1 /media/usb
    

To unmount it, just enter sudo umount /media/usb in the Terminal.

source

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.