Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Sony Vaio VPCSB1D7E (W7 + Ubuntu 12.04). It has hybrid graphics (AMD+Intel). I installed both the AMD Catalyst drivers and the Intel ones. So far, using both graphic cards works fine, but I have a problem when using the Intel card.

I cannot properly shutdown my laptop when I select the Intel card. It actually works well when using it. Then, when I shutdown the laptop, the console appears showing the shutdown process and stops in the line "shutdown laptop mode". Then, I have to long-press the shutdown button to switch off the laptop.

This only happens when using Intel's card, not AMD. Please let me know what appropriate logs would be useful to try to solve this problem.

Thanks!

share|improve this question
    
been having a similar problem. any luck? –  benj May 16 '13 at 22:53
1  
Hi. Seems to be solved with the latest kernel version. Not a clue about why it happened before but it seems fixed so far. –  Raúl May 20 '13 at 19:17
    
Thanks Raul. Can you give me a few more details? Do you mean a kernel update for 12.04 or are you now on 13.04? I'm sticking to 12.04 for the meanwhile but have to do the 10s force poweroff whenever I set catalyst to use the Intel GPU which I use most of the time. –  benj May 21 '13 at 11:00
    
Upgrading to Catalyst 13.4 on Ubuntu 12.04 solved my shutdown problems. –  benj Jun 1 '13 at 12:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.