Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running Ubuntu 12.04, and I'm having the following problems:

  1. My monitor is not detected properly. In System Settings -> Display it says Laptop even though it is a desktop PC (a fairly standard Dell monitor).
  2. My second monitor (identical with the first one) is not recognized at all.
  3. All the other settings cannot be changed, e.g. for resolution there is only the "1680:1050 (16:10)" option, for rotation only "normal" is displayed, etc. The "Mirror" switch is set to off even though I have the same image on both monitors all the time.

The open source and the proprietary drivers do not differ in their behavior. I think this is due to the fact that the proprietary drivers do not actually get loaded at all (more on this further down).

Since I have a ATI FirePro 2770 graphics card, all the guides and questions/answers I found when searching for solutions led to installing "fglrx". Once installed fglrx I got this:

fglrxinfo
X Error of failed request: BadRequest (invalid request code or no such operation)
Major opcode of failed request: 153 (GLX)
Minor opcode of failed request: 19 (X_GLXQueryServerString)
Serial number of failed request: 12
Current serial number in output stream: 12

which seems to point out that the driver itself is not running properly. The drivers themselves I installed both via System Settings -> Additional Drivers as well as manually via the console following different guides. When performing the manual process everything worked like a charm, even and including the last step aticonfig --initial . After rebooting though, nothing changed, and the problems were still the same.

Moving on ... Checking /var/log/Xorg.0.log I found:

[ 27.603] (II) ATI Proprietary Linux Driver Build Date: Mar 12 2012 13:06:47
[ 27.603] (II) VESA: driver for VESA chipsets: vesa
[ 27.603] (II) FBDEV: driver for framebuffer: fbdev
[ 27.603] (++) using VT number 7

[ 27.603] (WW) xf86OpenConsole: setpgid failed: Operation not permitted
[ 27.603] (WW) xf86OpenConsole: setsid failed: Operation not permitted
[ 27.604] (WW) Falling back to old probe method for pvr
[ 27.604] (WW) Falling back to old probe method for fglrx
[ 27.607] (II) Loading PCS database from /etc/ati/amdpcsdb
[ 27.608] (WW) fglrx: No matching Device section for instance (BusID PCI:0@1:0:0) found

There are more log entries regarding fglrx, but since it's quiet verbose I am not sure what to copy here. There is mentioning of the module being unloaded shortly after the above messages. What I can tell is that the framebuffer is starting up, so apparently no suitable driver was selected/initiated.

I tried booting into Ubuntu without X or at least stopping it (with /etc/init.d/lightdm stop ), so I could run Xorg -configure (a friend of mine gave me that advice), but I was unable to do so. X always seems to be running, even after telling lightdm to stop (at least Xorg complains about X already running).

This worked properly until yesterday. I had to reboot yesterday, and since then it just refuses to get back working. I checked my aptitude log to see if there were any updates which might have caused this and I found:

xserver-xorg-video-intel:i386 2:2.17.0-1ubuntu4.3 -> 2:2.17.0-1ubuntu4.4

which I installed about a week ago (might not have restarted since then). I checked the change log for this but it only mentions some security fix. I don't even know if this is of relevance at all.

I checked the device itself as well. The card seems OK, no marks, burns or whatever. Both monitors are connected via the same plug, and both monitors show exactly the same images.

I'm at a loss here, since I have absolutely no idea left. Can someone point out to me what I might be doing wrong here? I'll be happy to supply more information.

Update: I just noticed I cannot "attach" my windows to the top/side of the screen any longer. Before they would expand to the whole screen (top) or to half the screen (side) when touching the top or side. Now they are simply moved to the new position without any sort of expansion - both with the opensource and the proprietary drivers.

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.