Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

after I started to install the vmware tools in the vm machine and rebooted system prompted to use the shell for a while, but this seems to take forever

I ran TOP and can see vmtoolsd is there running

I did have where I think might be a concern, when installing the tools, prompted for the kernel header file, seems I didn't manage to point it to the correct location. but anyways I am not stopped there.

but currently the installation don't seem to proceed, how can I verify the progress of the tooling installation? can I re-do the process? and is there a more convinient way to install the vmware tools to the vm machien ?

my current screen :



vmware easy install

please wait! vmware tools is currently being installed on your system. depending on the version of ubuntu you are installing. you may login in below and use the system during the installation. otherwise, please wait for the graphical environment to lanuch. Thank you.



I did the following to installation

  1. mirror the installation package which sit under the vmware folder ( searched result told me that the vmware tool is name as linux.zip )

  2. copy that installation file to /tmp and started to install

share|improve this question
    
How did you actually installed VMWare tools? –  Mitch Apr 25 '13 at 12:09
    
sudo apt-get install build-essential linux-headers-$(uname -r) , then re run sudo vmware-config-tools.pl –  Qasim Apr 25 '13 at 12:47
    
@XxxXxx obiviously not catching my point, I've gone past that. and stuck with the startup screen –  zinking Apr 25 '13 at 13:21

2 Answers 2

I would just use the open-source VMware tools from the Ubuntu repository if I were you. They work as well as, or better than, the package from VMware for most needs. And, as you have noticed, using the VMware tools installer is a pain in the neck.

Just:

sudo apt-get install open-vm-tools

More details: http://open-vm-tools.sourceforge.net/about.php

share|improve this answer

There are a lot of possibilities that could be the cause of this. We can't give you a straight answer without more details. But anyways, it could be...

  • A broken VMware install (corrupt VMware Tools ISOs)

    • Solution: Reinstall VMware
  • Your computer does not have good enough specs for this, so it hangs

    • Solution: None, other than upgrading your PC
  • Your Ubuntu install may be damaged

    • Solution: Verify the integrity of your ISO and if it is corrupt re-download it and reinstall Ubuntu.
  • Your version of VMware/VMware tools may not support Ubuntu 12.10.

    • Solution: Update VMware and check VMware KB articles to see if there is a known bug.

Have you tried cancelling, cleaning up, and trying again? This is all we can do without more info like your VMware version, computer specs, etc.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.