Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed a fresh Ubuntu 12.10 and it still keeps asking me for password.

I've spent a few days of searching on net without any luck. I tried loading different drivers, using wicd instead of network-manager, re-configuring router, but still no luck.

There are many threads already about this issue, but none solved my issue. I have a USB wifi dongle Netgear WNA1000M and the driver was installed automatically. Although, when I choose a network to connect to, enter the password, it keeps prompting me for password again.

Cable connection works good.

I've run out of ideas. Can you please suggest further?

Thank you! Lukas

share|improve this question
Follow the steps in this answer. If it doesn't work, open a terminal (Ctrl+Alt+T) and type sudo service network-manager restart and try again. –  Alaa Jul 14 '13 at 5:18
And if it does not work, try this answer. If any of these solved your issue, let us know which one did. –  Alaa Jul 14 '13 at 5:24
add comment

1 Answer 1

I had this problem. I messed around with drivers and different distros but nothing worked.

I solved it by changing my router settings from n only to g/n.

share|improve this answer
add comment

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.