Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've had my Ubuntu 12.10 Server up and running for just over 2 months now and all was working well until I started to fiddle a little. I wanted to be able to login from my Windows 7/8 computers via X11RDP. So I was trying to set this up. However since fiddling with it I can no longer login via Xvnc, SSH or anything else outside of my network. Only SSH works within my network. When I try to login via RDP with my normal user it comes up and says "error connecting". If I login via Root, it will pass authentication but only load the wallpaper and nothing else.

I have checked a port checker online and it now shows my ports 22 and 5900 as closed, where as according to UFW they are open. I can ping the server. I have disabled the firewall and tried logging in again, still won't work. I have tried 16bit, 8bit and 32bit colour options. I've tried logging in via X11RDP, it connects fine then closes the window.

When I try and Xvnc it comes up with connecting to 127.0.0.1 5911. I'm fairly sure the other day the port was 5901. Whereas it should be 5900? It seems strange to me that both my external RDP and SSH connections failed the same time and I can no longer access either external and only SSH internal.

I am new to Linux and Ubuntu so please provide as much detail as possible and command line commands.

Any help would be appreciated.

Update: I've updated to 13.04, external SSH is now working. Xvnc same as before.

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.