Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I got the following error after installing VLC on my Quantal 12.10. Checked for libass4 and its already there. Is there anybody encountering this same silly error and willing to resolve..??

priyevsingh@priyevsingh-K43U:~$ sudo apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
0 upgraded, 0 newly installed, 0 to remove and 30 not upgraded.
4 not fully installed or removed.
Need to get 0 B/56.2 kB of archives.
After this operation, 0 B of additional disk space will be used.
dpkg: error processing libass4:amd64 (--configure):
 package libass4:amd64 is not ready for configuration
 cannot configure (current status `half-installed')
dpkg: dependency problems prevent configuration of vlc-nox:
 vlc-nox depends on libass4 (>= 0.9.7); however:
  Package libass4:amd64 is not installed.

dpkg: error processing vlc-nox (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of vlc-plugin-notify:
 vlc-plugin-notify depends on vlc-nox (= 2.0.6+git20130423+r563-0~r46~quantal1); however:
  Package vlc-nox is not configured yet.

dpkg: error processing vlc-plugin-notify (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of vlc-plugin-pulse:
 vlc-plugin-pulse depends on vlc-nox (= 2.0.6+git20130423+r563-0~r46~quantal1); however:
  Package vlc-nox is not configured yet.

dpkg: error processing vlc-plugin-pulse (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              Errors were encountered while processing:
 libass4:amd64
 vlc-nox
 vlc-plugin-notify
 vlc-plugin-pulse
E: Sub-process /usr/bin/dpkg returned an error code (1)
priyevsingh@priyevsingh-K43U:~$ 
share|improve this question

3 Answers 3

Try reinstalling libass4, there seems to be something wrong with the current installation.

share|improve this answer

ah! resolved somehow...

http://ftp.cn.debian.org/debian/pool/main/liba/libass/libass4_0.10.0-3_amd64.deb

Extract and install:

sudo dpkg -i '/location/to/file/libass4_0.10.0-3_amd64.deb' 
share|improve this answer

I also faced same problem. To resolve this I did

Open software center.

From edit click on software source

Under Ubuntu Software tab, enable all the repositories except source code and click on download from

Select other from download drop down

Now click on select best server

Once Ubuntu select best server for you click on chose server

Now click on other software tab.

Remove any entry if you found for VLC. And click on close.

Press ALT + CTRL+T key combination to open the terminal and run following command

sudo apt-get clean
sudo apt-get -f install
sudo apt-get update
sudo apt-get upgrade

After upgrading reboot the system.

After reboot try again to install VLC. Run following commands

sudo add-apt-repository ppa:videolan/stable-daily
sudo apt-get update
sudo apt-get install vlc

Source : - http://computernetworkingnotes.com/ubuntu-12-04-tips-and-tricks/how-to-install-vlc-in-ubuntu.html

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.