Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

This is my problem

How do I fix this? Please note I am using quantal. I performed the change shown here.

Edit: I upgraded to raring and the problem went away. A little while later I logged off and logged back on. The problem showed up again. I think it has something to do with the action of logging on and off.

share|improve this question

marked as duplicate by david6, Eric Carvalho, AgentCool, user68186, Thomas W. May 24 '13 at 14:12

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
This is an experiment and as I guess , it failed. Do you know how to go back to the original settings ? –  NikTh Apr 25 '13 at 0:40
    
What is an experiment? If you are talking about the changing of the dash icon I can say with complete confidence that is not the case. sudo apt-get install --reinstall unity-common is how you get the original icon back. I tried that. Nothing. Either way I changed the icon 3 months ago. I highly doubt that is what caused this. I only included it so people wouldn't think I was on raring –  chad Apr 25 '13 at 11:26
    
Ah, ok. I thought that when you changed the icon pack , you had this behavior. My bad. Then the problem is either with graphics card driver or the configuration of compiz-settings ..etc. For the graphics card driver , try to re-install. For configuration, you can try to reset all the configs you have done and see if this is the case. Be aware that you will lose EVERYTHING about configuration (wallpaper - keyboard layout - icons maybe.. ) , Ubuntu will revert back to a primary state. The command to delete all the configs is a little bit dangerous. I don't know if I'm allowed to post it here. –  NikTh Apr 25 '13 at 12:08
    
is this it? dconf reset -f /org/compiz/ –  chad Apr 25 '13 at 18:21
    
No , this is just the reset command. I speak about delete.. delete all the compiz and config settings. –  NikTh Apr 25 '13 at 21:43

3 Answers 3

up vote 3 down vote accepted

Removing the gnome 3 ppa fixes the problem.

Execute the commands

sudo apt-get install ppa-purge
sudo ppa-purge ppa:gnome3-team/gnome3

I am unsure as to why this fixed my problem. This answer is not my own however. He(or she) answered another question of mine here. When fixing that issue it also solved this one. He(or she) refused to answer this one and receive the bounty because he did not understand why Gnome 3.8 would cause this issue.

This happens because you got Nautilus 3.8 as a part of GNOME 3.8. Nautilus 3.8 removes the code used to draw the desktop background and icons. Instead, it is intended that gnome-shell draws the desktop, but since Unity uses Nautilus to draw the desktop, you get a white background because as of 3.8, Nautilus no longer knows how.

share|improve this answer

Procedure below has been tested by me , on both Ubuntu 12.04 & 12.10.

You can try to reset (DELETE) all your configuration settings and see if problem fixed.

Be aware that Ubuntu will revert back to a primary state. You will not lose any personal files..but you will lose

  • Probably Icons
  • Wallpaper
  • Keyboard Layout
  • Changes in Launcher - nautilus - and lot of programs.

First we will create a backup in case that something goes wrong.

Open a terminal (CTRL+ALT+T) and execute the following commands one by one

gconftool --shutdown
sudo killall -r -I gconf
sudo killall -r -I dconf
tar czf confbackup.tar.gz .compiz* .gconf* .config/dconf/ .config/compiz*

Now you have a backup of your current settings inside your /home directory named : confbackup.tar.gz

By execute the following command you will delete all of your settings.

Please copy-paste from here. Do not make a mistake because you can damage your system.

rm -rf .compiz* .gconf* .config/dconf/ .config/compiz*

Last , reboot your system and see if your problem fixed.

Restore (in case of a serious problem)

gconftool --shutdown
sudo killall -r -I gconf
sudo killall -r -I dconf
rm -rf .compiz* .gconf* .config/dconf/ .config/compiz*
tar xzvf confbackup.tar.gz
sudo reboot

Above commands will can be executed from a terminal , either from a console mode (CTRL+ALT+F2) and will restore all the settings you have deleted.

Source(GR Language)

share|improve this answer
    
What purpose is the backup? –  chad May 7 '13 at 0:06
    
I tried this. No luck –  chad May 7 '13 at 21:33
    
These command do not have correct syntax. If you need to try this drastic fix (which does work), get syntax from: askubuntu.com/questions/287571/… OR answers.launchpad.net/ubuntu/+question/217369 –  david6 May 24 '13 at 8:28
    
@david6: If you think that the commands have not correct syntax you could edit my answer. Do not redirect the user to other answers. Except of this I have already tried all the commands above and worked as it should. –  NikTh May 24 '13 at 8:56
    
I re-checked other sources (and killall systax). I have instead corrected the other AskUbuntu answer (to match yours). ALSO: This fixes symptoms, but not the actual cause. –  david6 May 24 '13 at 10:19

unity-tweak-tool

Ubuntu 13.04

 sudo apt-get install unity-tweak-tool

Unity Tweak Tool is also available for Ubuntu 12.10 in a daily PPA. If you want to add the PPA and install it in Ubuntu 12.10, use the commands below:

 sudo add-apt-repository ppa:freyja-dev/unity-tweak-tool-daily
 sudo apt-get update
 sudo apt-get install unity-tweak-tool

Open Unity Tweak Tool

Click On Launcher

enter image description here

Check The option ' Colour : Based On Wallpaper '

enter image description here

I hope this will fix your issue

share|improve this answer
    
Nope sorry. Those settings are already enabled –  chad May 9 '13 at 20:58

Not the answer you're looking for? Browse other questions tagged or ask your own question.