Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So I installed Ubuntu 12.10 32 bit, as was recommended. I used the windows installer (Wubi). I rebooted my computer and when the choices of which OS I would like to start I choose Ubuntu. After i press enter it just goes to what i am thinking is a command prompt screen.

It has the word grub>. I do not know what to do next. I tried a few command prompts but nothing

I am using an IBM think Pad with a Pentium M 1600MHz processor 512 RAM did I do something wrong? do i need the 64 bit? or do i need the 12.04 download? how do i uninstall it if i need to.

share|improve this question
    
1  
What is the output of search -s -f -n /ubuntu/disks/root.disk and echo $root? –  bcbc Apr 25 '13 at 18:05
add comment

1 Answer

I had the same problem. what i had to do was to uninstall everything i had on my laptop and install ubuntu. That was foolish of me. And fortunately, my Ubuntu still did not boot, and showed a grub prompt. later i realised that this was a UEFI mode problem. What you need to do is

First, disable uefi boot mode. and then try installing ubuntu. (NOTE: the problem isnt with your ubuntu 12.10 image). you also need to disable your secure boot. install in legacy boot mode.

OR

Second, live run your ubuntu OS, use boot repair. this must be added using apt-get repository. OR use LINUX SECURE REMIX which is essentially made to solve this problem of dual booting. it comes with a preinstalled package called boot repair, run it to modify your booting options in favour of your linux distribution. simply live run your Operating system ie Ubuntu and run boot repair available in the dock on the left. then install the OS.

this worked for me. here is the reference for more technical info and the link to the linux secure remix image. https://help.ubuntu.com/community/LinuxSecureRemix

share|improve this answer
    
Note, the OP said he installed Ubuntu using WUBI in a Pentium M box which was probably built long before UEFI came into our world. –  user68186 Apr 25 '13 at 19:15
    
my bad.. in that case,i think u need to reinstall grub. for me, the remedy was UEFI disabling. reinstall grub using ubuntu live run. refer this for more details. link @user68186 –  Yashkaran Singh Apr 26 '13 at 17:50
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.