Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed Raring last night and everything was going fine until I went to get AWM up and running.

Originally I planned to use the version from the official repos ignoring how outdated it was, but the log-in screen would not allow me to switch DE's.

So I tried using Klaus Vormweg's updated unofficial PPA and the exact same issue happened.

No matter what I do, the Ubuntu log-in will not display Awesome in the list of available DE's. At first I thought it might be the same for every environment, but I was able to install and switch to a Gnome Fallback proving that theory wrong...

Is this an issue with Raring, or PEBKaC?

P.S. I realize this question doesn't have much in-depth information behind it as I'm at my work PC now, but any terminal output you all require I'd be glad to provide once I get home.

share|improve this question
    
What do you see listed in /usr/share/xsessions? I think only the desktops listed there may appear in the log-in list. Unless some special measures are taken, I wouldn't expect a window manager to be listed in the log-in session. (Openbox is listed for a vanilla Lubuntu 13.04 session.) –  user25656 Apr 25 '13 at 3:31
    
@vasa1 I see awesome, GNOME, and Ubuntu as of now, but I'm not even getting the option to switch at the log-in screen. I've purged the Gnome Fallback and the button just isn't there like it normally would be. –  UrLossMyGain Apr 25 '13 at 8:18
    
Could you look at the entry for AWM by right-clicking on it in a file manager and choosing to open with a text editor? (Otherwise, open it using nano or whatever in a terminal.) Is there a line like NoDisplay=True? If there's no such line, then I'm out of suggestions! –  user25656 Apr 25 '13 at 8:49
4  
This is a bug, everyone affected please follow this: bugs.launchpad.net/ubuntu/+source/awesome/+bug/1094811 –  Jorge Castro Apr 25 '13 at 18:02
1  
Comment #8 in the bug indicates that deleting NoDisplay=true does the trick until the bug is fixed. –  user25656 Apr 26 '13 at 3:09
show 2 more comments

closed as off topic by jokerdino Apr 25 '13 at 18:35

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.