Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a problem get the WiFi to work in Ubuntu 12.10. When I use gnome network manager it indicates that wireless is disabled by hardware switch while it is not.

In the Network Settings Panel in the wireless section, it only shows the hardware address and the switch is off and it's disabled so that I can't change the status to On. At the bottom there is an airplane mode switch which is On, and turning it off has no effect and it immediately turns back on. I use a sony vaio CA series Laptop

share|improve this question

1 Answer 1

This worked for me:

Enter rfkill unblock all in Terminal and then try to enable wireless, it should work now.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.