Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The problem is that if I make an entry in /etc/fstab to mount a samba share I can give the option iocharset=utf8 and this then mounts the share correctly and in the right encoding with special characters displayed correctly.

Gnomes automount system for some reason never gets this right and I can find nowhere to change its settings.

Is there a way to make it always use UTF8 by default?

This is with Ubuntu 10.10 and the system can display the characters involved.

share|improve this question

1 Answer 1

gvfs-smb uses libsmbclient which uses the normal configuration for Samba for encoding. Have you tried setting unix charset = utf-8 in your /etc/samba/smb.conf?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.