Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I tried installing gpp in my Ubuntu 12.04, but I can't install it.

It reports,

sudo apt-get install gpp
[sudo] password for akash:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package gpp

I tried locating the file gpp by

find / -type f -name gpp

But it says permission denied in all course.

share|improve this question
It's worth noting that GPP is the GNU Preprocessor; G++ is the name of the GNU C++ compiler. – Andrea Corbellini May 3 '13 at 12:47
possible duplicate of Can I use a C/C++ compiler? – Eliah Kagan Sep 9 '14 at 19:44

The best way to install all the basic development tools is to do

sudo apt-get install build-essential

share|improve this answer

The package gpp is contained in the universe group of the repository, you need to add it to the software sources either in the graphical tool or editing the /etc/apt/sources.list file. It should contain the line deb precise universe.

EDIT: If you want the GNU C++ compiler, the package name is g++, and it's in the main section of the repository.

share|improve this answer

Try this :

sudo apt-get install g++
share|improve this answer
You might need to run apt-get update first. – Seth Apr 3 '14 at 15:55

protected by Community Apr 3 '14 at 15:55

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.