Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using Asus U56E laptop and after installing Ubuntu 12.10 alongside Windows 8, I am unable to connect to the Wireless. I have been trying to solve this problem since two weeks and couldn't solve it. Please help. Any answer would be appreciated.

Here are some command-line results.

lspci -v | grep -iA 7 network

ubuntu@ubuntu:~$ lspci -v | grep -iA 7 network
    02:00.0 Network controller: Intel Corporation Centrino Wireless-N + WiMAX 6150 (rev 67)
    Subsystem: Intel Corporation Centrino Wireless-N + WiMAX 6150 BGN
    Flags: bus master, fast devsel, latency 0, IRQ 52
    Memory at de800000 (64-bit, non-prefetchable) [size=8K]
    Capabilities: <access denied>
    Kernel driver in use: iwlwifi
    Kernel modules: iwlwifi

lsmod | grep iwlwifi

ubuntu@ubuntu:~$ lsmod | grep iwlwifi

iwlwifi               386826  0 

mac80211              539908  1 iwlwifi
cfg80211              206566  2 iwlwifi,mac80211
ubuntu@ubuntu:~$ dmesg | grep iwlwifi
[   57.846261] iwlwifi: Intel(R) Wireless WiFi Link AGN driver for Linux, in-tree:
[   57.846264] iwlwifi: Copyright(c) 2003-2012 Intel Corporation
[   57.846336] iwlwifi 0000:02:00.0: >pci_resource_len = 0x00002000
[   57.846338] iwlwifi 0000:02:00.0: >pci_resource_base = ffffc90000c7c000
[   57.846341] iwlwifi 0000:02:00.0: >HW Revision ID = 0x67
[   57.846438] iwlwifi 0000:02:00.0: >irq 52 for MSI/MSI-X
[   59.558335] iwlwifi 0000:02:00.0: >loaded firmware version 41.28.5.1 build 33926
[   59.558514] iwlwifi 0000:02:00.0: >CONFIG_IWLWIFI_DEBUG disabled
[   59.558516] iwlwifi 0000:02:00.0: >CONFIG_IWLWIFI_DEBUGFS enabled
[   59.558517] iwlwifi 0000:02:00.0: >CONFIG_IWLWIFI_DEVICE_TRACING enabled
[   59.558519] iwlwifi 0000:02:00.0: >CONFIG_IWLWIFI_DEVICE_TESTMODE enabled
[   59.558520] iwlwifi 0000:02:00.0: >CONFIG_IWLWIFI_P2P disabled
[   59.558522] iwlwifi 0000:02:00.0: >Detected Intel(R) Centrino(R) Wireless-N + WiMAX 6150 BGN, REV=0x84
[   59.558583] iwlwifi 0000:02:00.0: >L1 Disabled; Enabling L0S
[   59.569083] iwlwifi 0000:02:00.0: >device EEPROM VER=0x557, CALIB=0x6
[   59.569085] iwlwifi 0000:02:00.0: >Device SKU: 0x150
[   59.569087] iwlwifi 0000:02:00.0: >Valid Tx ant: 0x1, Valid Rx ant: 0x3
[   59.569100] iwlwifi 0000:02:00.0: >Tunable channels: 13 802.11bg, 0 802.11a channels
[   70.208469] iwlwifi 0000:02:00.0: >L1 Disabled; Enabling L0S
[   70.208648] iwlwifi 0000:02:00.0: >Radio type=0x1-0x2-0x0
[   70.366319] iwlwifi 0000:02:00.0: >L1 Disabled; Enabling L0S
[   70.366470] iwlwifi 0000:02:00.0: >Radio type=0x1-0x2-0x0

sudo lshw -c network

 ubuntu@ubuntu:~$ sudo lshw -c network
      *-network               
           description: Wireless interface
           product: Centrino Wireless-N + WiMAX 6150
           vendor: Intel Corporation
           physical id: 0
           bus info: pci@0000:02:00.0
           logical name: wlan0
           version: 67
           serial: 40:25:c2:84:99:c4
           width: 64 bits
           clock: 33MHz
           capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
           configuration: broadcast=yes driver=iwlwifi driverversion=3.5.0-17-generic firmware=41.28.5.1 build 33926 latency=0 link=no multicast=yes wireless=IEEE 802.11bgn
           resources: irq:52 memory:de800000-de801fff
      *-network
           description: Ethernet interface
           product: AR8151 v2.0 Gigabit Ethernet
           vendor: Atheros Communications Inc.
           physical id: 0
           bus info: pci@0000:04:00.0
           logical name: eth0
           version: c0
           serial: 54:04:a6:2b:6a:ef
           capacity: 1Gbit/s
           width: 64 bits
           clock: 33MHz
           capabilities: pm msi pciexpress vpd bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
           configuration: autonegotiation=on broadcast=yes driver=atl1c driverversion=1.0.1.0-NAPI latency=0 link=no multicast=yes port=twisted pair
           resources: irq:54 memory:dd400000-dd43ffff ioport:a000(size=128)

ifconfig

ubuntu@ubuntu:~$ ifconfig
    eth0      Link encap:Ethernet  HWaddr 54:04:a6:2b:6a:ef  
              UP BROADCAST MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

    lo        Link encap:Local Loopback  
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:176 errors:0 dropped:0 overruns:0 frame:0
              TX packets:176 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0 
              RX bytes:14368 (14.3 KB)  TX bytes:14368 (14.3 KB)

    wlan0     Link encap:Ethernet  HWaddr 40:25:c2:84:99:c4  
              UP BROADCAST MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

iwconfig

ubuntu@ubuntu:~$ iwconfig
eth0      no wireless extensions.

lo        no wireless extensions.

wlan0     IEEE 802.11bgn  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=15 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off

iwlist scan

ubuntu@ubuntu:~$ iwlist scan
eth0      Interface doesn't support scanning.

lo        Interface doesn't support scanning.

wlan0     No scan results

nm-tool

ubuntu@ubuntu:~$ nm-tool

NetworkManager Tool

State: disconnected

- Device: eth0 -----------------------------------------------------------------
  Type:              Wired
  Driver:            atl1c
  State:             unavailable
  Default:           no
  HW Address:        54:04:A6:2B:6A:EF

  Capabilities:
    Carrier Detect:  yes

  Wired Properties
    Carrier:         off


- Device: wlan0 ----------------------------------------------------------------
  Type:              802.11 WiFi
  Driver:            iwlwifi
  State:             disconnected
  Default:           no
  HW Address:        40:25:C2:84:99:C4

  Capabilities:

  Wireless Properties
    WEP Encryption:  yes
    WPA Encryption:  yes
    WPA2 Encryption: yes

  Wireless Access Points 
    hypeness2:       Infra, 00:21:29:DA:08:4F, Freq 2462 MHz, Rate 54 Mb/s, Strength 42 WPA
    love:            Infra, 68:7F:74:17:02:66, Freq 2412 MHz, Rate 54 Mb/s, Strength 19 WPA WPA2
    DIRECT-MwSCX-3400Pamela: Infra, 02:15:99:A3:3F:AC, Freq 2412 MHz, Rate 54 Mb/s, Strength 22 WPA2
    router:          Infra, 1C:AF:F7:D6:76:F3, Freq 2417 MHz, Rate 54 Mb/s, Strength 20 WPA2
    wing:            Infra, E8:40:F2:34:E4:F7, Freq 2437 MHz, Rate 54 Mb/s, Strength 20 WPA WPA2
    132LINKSYS:      Infra, 00:1A:70:80:1F:E9, Freq 2437 MHz, Rate 54 Mb/s, Strength 57 WEP
    VMITTAL:         Infra, E0:46:9A:3C:F0:C4, Freq 2412 MHz, Rate 54 Mb/s, Strength 27 WEP
    HP-Print-10-LaserJet 1025: Infra, 7C:E9:D3:7E:F8:10, Freq 2437 MHz, Rate 54 Mb/s, Strength 59
    ACNBB:           Infra, 00:26:75:22:A6:2F, Freq 2437 MHz, Rate 54 Mb/s, Strength 20
    SATKAIVAL:       Infra, 00:18:E7:CE:69:A6, Freq 2412 MHz, Rate 54 Mb/s, Strength 69 WPA WPA2
    hypeness:        Infra, B8:E6:25:24:C3:B1, Freq 2437 MHz, Rate 54 Mb/s, Strength 54 WPA WPA2
    CSNetwork:       Infra, BC:14:01:58:C5:88, Freq 2437 MHz, Rate 54 Mb/s, Strength 25 WPA WPA2
    tharma:          Infra, BC:14:01:E2:06:18, Freq 2412 MHz, Rate 54 Mb/s, Strength 15 WPA WPA2
    Active2.4:       Infra, 10:6F:3F:0E:F3:8E, Freq 2462 MHz, Rate 54 Mb/s, Strength 17 WPA WPA2
    ACNBB:           Infra, 00:26:75:58:4E:7A, Freq 2437 MHz, Rate 54 Mb/s, Strength 85
    KO:              Infra, BC:14:01:2E:AF:A8, Freq 2452 MHz, Rate 54 Mb/s, Strength 22 WPA WPA2
    FEAR:            Infra, 00:18:4D:C0:BC:58, Freq 2462 MHz, Rate 54 Mb/s, Strength 17 WPA
    Pamela:          Infra, BC:14:01:52:F6:F8, Freq 2412 MHz, Rate 54 Mb/s, Strength 24 WPA WPA2
    bvrk2:           Infra, 78:CD:8E:7B:3C:79, Freq 2457 MHz, Rate 54 Mb/s, Strength 19 WPA WPA2
    BELL030:         Infra, D8:6C:E9:17:AF:09, Freq 2462 MHz, Rate 54 Mb/s, Strength 22 WPA2
    Desai:           Infra, 00:1D:7E:52:FB:C5, Freq 2437 MHz, Rate 54 Mb/s, Strength 14 WEP
    Sritharan:       Infra, BC:14:01:E5:59:78, Freq 2462 MHz, Rate 54 Mb/s, Strength 19 WPA WPA2
    PFN:             Infra, 00:13:10:8B:CF:45, Freq 2437 MHz, Rate 54 Mb/s, Strength 19 WEP

rfkill list all

ubuntu@ubuntu:~$ rfkill list all
0: asus-wlan: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: asus-wimax: WiMAX
    Soft blocked: yes
    Hard blocked: no
2: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no

so these are some more results

sudo modprobe -r iwlwifi

ubuntu@ubuntu:~$ sudo modprobe -r iwlwifi

sudo modprobe iwlwifi 11n_disable=1

ubuntu@ubuntu:~$ sudo modprobe iwlwifi 11n_disable=1

echo "blacklist asus_wmi" | sudo tee -a /etcmodprobe.d/blacklist.conf

ubuntu@ubuntu:~$ echo "blacklist asus_wmi" | sudo tee -a /etc/modprobe.d/blacklist.conf
blacklist asus_wmi

echo "options iwlwifi 11n_disable=1" | sudo tee /etc/modprobe.d/iwlwifi.conf

ubuntu@ubuntu:~$ echo "options iwlwifi 11n_disable=1" | sudo tee /etc/modprobe.d/iwlwifi.conf
options iwlwifi 11n_disable=1

sudo modprobe -rfv iwlwifi

ubuntu@ubuntu:~$ sudo modprobe -rfv iwlwifi
rmmod /lib/modules/3.5.0-17-generic/kernel/drivers/net/wireless/iwlwifi/iwlwifi.ko
rmmod /lib/modules/3.5.0-17-generic/kernel/net/mac80211/mac80211.ko
rmmod /lib/modules/3.5.0-17-generic/kernel/net/wireless/cfg80211.ko

sudo modprobe -v iwlwifi

ubuntu@ubuntu:~$ sudo modprobe -v iwlwifi
insmod /lib/modules/3.5.0-17-generic/kernel/net/wireless/cfg80211.ko 
insmod /lib/modules/3.5.0-17-generic/kernel/net/mac80211/mac80211.ko 
insmod /lib/modules/3.5.0-17-generic/kernel/drivers/net/wireless/iwlwifi/iwlwifi.ko 11n_disable=1
share|improve this question
    
can you try the steps mentioned here: ubuntuforums.org/showthread.php?t=2010968 see if those helps. If they do I will provide the answer here in a friendlier format. I do not have the same Wifi Card to test. So please, test it with the suggestions mentioned there and see if that helps. –  Luis Alvarado Apr 26 '13 at 23:05
    
that didn't solve the problem –  chipChocolate.py Apr 28 '13 at 20:06

1 Answer 1

This will keep power management enabled, but it will limit your wifi speed and range to 802.11g speeds.

  1. Run the following commands

    sudo rmmod iwlwifi
    sudo modprobe iwlwifi 11n_disable=1
    
  2. Make sure that wireless connectivity is restored. To make this change permanent, create a new file in /etc/modprobe.d and put the following in it:

    options iwlwifi 11n_disable=1
    
  3. Reboot to see changes.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.