Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I have a laptop with in-built windows 8. I installed Ubuntu 64 bit via the method shown on this Ubuntu page: https://help.ubuntu.com/community/UEFI

After use boot-repair, in GRUB menu it shows Windows 8 as well. But on clicking it, it shows errors.

share|improve this question

marked as duplicate by Kevin Bowen, Thomas W., Radu Rădeanu, Mitch, gertvdijk Jun 23 '13 at 22:15

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1  
Welcome to Ask Ubuntu! Could you show the errors? –  Lucio Apr 24 '13 at 0:10
    
What is the URL provided by the Recommended Repair of Boot-Repair ? –  LovinBuntu Apr 24 '13 at 19:25
add comment

2 Answers 2

Reporting the precise errors you're seeing might be a helpful diagnostic. Chances are, though, that you haven't broken your Windows; it's probably just a GRUB problem. Some ideas for getting it working:

  • Install rEFInd. Installing the Debian package should set it up properly; however, you might need to do the next thing, too.
  • Disable Secure Boot. Details of how to do this vary from one system to another, but as a general rule, you'll need to enter your firmware's setup utility and look for an option labeled "Secure Boot" to disable it.
  • Create a custom boot entry for Windows, via an entry in /etc/grub.d/40_custom, as shown below. Details will vary depending on where your EFI System Partition (ESP) is, though. After you create this entry, you'll need to type sudo update-grub to update GRUB's runtime configuration file.

The sample /etc/grub.d/40_custom entry is:

menuentry "Windows 8" {
    insmod part_gpt
    insmod chain
    set root='(hd0,gpt1)'
    chainloader /EFI/Microsoft/Boot/bootmgfw.efi
}

Note that (hd0,gpt1) must point to your ESP, so it may need to be changed to match your partitioning layout.

share|improve this answer
add comment

I also got this problem when I installed Ubuntu 64 bit (12.10) and you also like me messed up the Windows 8 boot partition. So now your only options are:

  • Re-install winidows 8
  • Fix the windows 8 boot

See also:

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.