Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to mount a NAS on one of my servers:

htadmin@testing:~$ showmount -e 10.0.0.210
Export list for 10.0.0.210:
/humanresources         
/Web                    
/Usb                    
/Recordings             
/Public                 
/Network Recycle Bin 1  
/Multimedia             
/Download               
/Data

Now I try to mount it:

sudo mount -o soft,intr,user_name=administrator,password=xxxxxxxx \
,rsize=8192,wsize=8192 10.0.0.210:/Data /mnt/nas

And I am presented with the following error message:

mount.nfs: an incorrect mount option was specified

Any help here would be great. Thanks!

share|improve this question
    
Try without the user_name and password options. I don't think that's how NFS authentication works –  cxrodgers Apr 29 '13 at 1:48
    
Try adding the filesystem type to the command line: -t nfs. nfs is not supported by the normal mount command. –  daniel kullmann Apr 29 '13 at 7:19
    
I don't think NFS supports giving a username/password. The access control is done on the server, which specifies which IP addresses to allow mounting an exported directory –  daniel kullmann Apr 29 '13 at 7:25
    
Did you created /mnt/nas directory? all the directories you will be using you need to create before, like: sudo mkdir /mnt/nas –  Rodrigo Martins Apr 29 '13 at 14:44
    
could also be a problem with NFS version - ubuntu default is NFSv4 as far as I know, and some NASes (Synology, looking at you!) only support NFS3. I remember having problems with that, and falling back to samba as a consequence. –  Christoph May 2 '13 at 13:38
add comment

2 Answers

I'd try issuing the command eliding options one by one, this way finding which one is incorrect; that would be a step forward in finding out the actual problem.

share|improve this answer
add comment
up vote 2 down vote accepted

Solution: sudo mount -t cifs //10.0.0.210/data -o username=xxxx,password=xxxx,rw,nounix,iocharset=utf8,file_mode=0644,dir_mode=0755 /mnt/nas

share|improve this answer
1  
aha, so it's not an NFS mount after all. that explains why you need username/password. makes sense now that I know it's samba/cifs –  cxrodgers May 1 '13 at 9:30
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.