Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

(Other terminals like gnome-terminal and sshing have no problem at all.)

Every 10 seconds, an error message (jme 0000:05:00.5: eth0: IPv4 Checksum error) constantly appears on the virtual terminal (which can be accessed by Ctrl + Alt + F1~6), and it annoys me because that makes using programss like vi or w3m very hard.

How to suppress that message on the terminal?

share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

This will happens due to upgrade of drivers to recent versions and you can fix it by disabling the checksum checking in your PC for that particular connection.

All you need to do is simply open your terminal and type as follow

sudo apt-get install ethtool

then disable checksum

ethtool --offload eth1 rx off tx off

that's it. It will stop giving error messages but this setting will be lost after restarting of your PC.

you would better make it as start up script.

hope that helps.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.