Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Currently I am working on a remote server using Ubuntu yet the 'd' key cannot be used since it minimizes/maximizes all windows to show/hide desktop. Many answers point to the fact that I should go to the shortcuts and disable the "Hide all windows..." mapping.

EDIT:

I did disable other similar mapping such as 'Hide all normal windows' which is set to disabled ( I Cleared it with my backspace). Yet this has no effect. Or do I need to log off and on again?

My problem is that I do not have this shortcut mapping listed in the shortcuts settings!


I also cannot find the global_keybindings directory that many solutions suggest..

I tried to use the character map when I needed 'd' but when I was asked to authenticate an installation of a programm (and my password has a 'd'), and I pasted the character, authentication failed. I don't know whether this is another issue or not.


I don't have to access to log on or off, so I restarted the VM from my Azure, yet the same trouble was present.

Can you advice any work around?


@Oli - I tried using xev to check out the keyboard events

I tried to press a normal letter 'b'

KeyPress event, serial 35, synthetic NO, window 0x4000001,
    root 0x2e, subw 0x0, time 910899804, (358,-354), root:(359,184),
    state 0x0, keycode 56 (keysym 0x62, b), same_screen YES,
    XLookupString gives 1 bytes: (62) "b"
    XmbLookupString gives 1 bytes: (62) "b"
    XFilterEvent returns: False

KeyRelease event, serial 35, synthetic NO, window 0x4000001,
    root 0x2e, subw 0x0, time 910900467, (358,-354), root:(359,184),
    state 0x0, keycode 56 (keysym 0x62, b), same_screen YES,
    XLookupString gives 1 bytes: (62) "b"
    XFilterEvent returns: False

----then I pressed 'd':

FocusOut event, serial 35, synthetic NO, window 0x4000001, mode
    NotifyGrab, detail NotifyAncestor FocusOut event, serial 35, synthetic
    NO, window 0x4000001, mode NotifyWhileGrabbed, detail NotifyNonlinear
UnmapNotify event, serial 35, synthetic NO, window 0x4000001, event
    0x4000001, window 0x4000001, from_configure NO PropertyNotify event,
    serial 35, synthetic NO, window 0x4000001, atom 0xc2 (WM_STATE), time
    910906044, state PropertyNewValue PropertyNotify event, serial 35,
    synthetic NO, window 0x4000001, atom 0xa2 (_NET_WM_STATE), time
    910906044, state PropertyNewValue PropertyNotify event, serial 35,
    synthetic NO, window 0x4000001, atom 0xa2 (_NET_WM_STATE), time
    910914112, state PropertyNewValue
share|improve this question
    
Once disabled, have you tried to log off and in again? –  Victor Apr 23 '13 at 8:29
    
I am currently working remotly from windows to ubuntu and I am not able to log on or off! –  test Apr 23 '13 at 8:44
    
which version of ubuntu are you using? On mine (13.04), changes are immediate and do not require relogin. You can also use dconf editor in org.gnome.desktop.wm.keybindings to change the show desktop function but it should be the same as in the normal settings... –  Victor Apr 23 '13 at 9:25
    
To me it sounds like your client is sending the Super/Meta/Windows (whatever you want to call it) key, all the time. Or that it's being erroneously sent. At the very least I'd try reconnecting and testing my hypothesis (load up xev remotely and press a few keys and see if it's triggering the SUPER key) –  Oli Apr 23 '13 at 9:29
1  
Launch the terminal (Ctrl+Alt+T, if that works) then 'xev' and enter. then press d and return the results in your question –  Victor Apr 23 '13 at 9:40
show 4 more comments

3 Answers

up vote 2 down vote accepted

On further investigation this does seems to be a widely noticed issue with XRDP. It's probably not the client sending rubbish along as I previously said in my comment, rather that it's the server doing weird stuff for an unknown reason.

Many people have documented that fixing this involves disabling the <Super>d binding for showing the desktop but this fix has had to evolve over the years as Ubuntu has upgraded components. There are a few basic options for doing the same thing:

Other people report other similar quirks with XRDP so if you're experiencing other issues (and/or you can't fix this one), it might be best to dump it and go with something else. There are a fair few to choose from but the main contenders are VNC (over SSH from Ubuntu, or over SSH from Windows with Putty) or FreeNX.

FreeNX is a lot less popular than VNC but it's a solid contender and a lot more like RDP than VNC (which can occasionally be a bit flabby if you're doing lots of graphics stuff). But VNC is easier to set up.

share|improve this answer
    
Thanks a lot for your info ! –  test Apr 23 '13 at 10:30
    
GConf was the solution! –  test May 7 '13 at 20:58
add comment

open Applications\System Tools\dconf Editor

navigate to:

org\gnome\desktop\wm\keybindings

then change the "show-desktop" keybinding to "[]"

share|improve this answer
add comment

open Applications\System Tools\dconf Editor

navigate to:

org\gnome\desktop\wm\keybindings

then change the "show-desktop" keybinding to "[]"

Make sure to log out and log back in. It's a good idea to stop and start vncserver, as well.

I am using ubuntu 13.04 and in my xstartup file I am using gnome-session --session=gnome-fallback &

Not sure how this works with other session types.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.