Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried to create the svn user in my server,and I create a new group svn and add the current user maven to the group svn.

sudo groupadd svn
sudo chgrp svn /usr/local/svn/repos
sudo usermod -a -G svn maven

Now I tried to remove subversion, and delete the groups.

Then I used:

sudo groupdel svn

When I tried to find the groups for my current user using:

groups

I got the messages:

maven@mac:/usr/local$ groups

maven adm cdrom sudo dip plugdev lpadmin sambashare vboxusers groups: cannot find name for group ID 1001
1001

How can I fix this?

share|improve this question
    
    
It does not work. I got gpasswd: group 'svn' does not exist in /etc/group when I use the gpasswd -d maven svn –  hguser Apr 24 '13 at 3:05

1 Answer 1

When you delete a group, all the users should be removed from the group as well when the command is called. You also have to log out and then log back in for new groups (or deleted groups) to show up when 'groups' is called.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.