Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I want to get a ppa key signed

I tried

apt-key adv --keyserver keyserver.ubuntu.com --recv-keys A258828C     

Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --secret-keyring /etc/apt/secring.gpg --trustdb-name /etc/apt/trustdb.gpg --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyserver keyserver.ubuntu.com --recv-keys A258828C
gpg: requesting key A258828C from hkp server keyserver.ubuntu.com
gpgkeys: HTTP fetch error 7: couldn't connect to host
gpg: no valid OpenPGP data found.
gpg: Total number processed: 0

and

wget -q http://ppa.launchpad.net/panda3d/ppa/ubuntu/dists/lucid/Release.gpg -O- | apt-key add -

gpg: no valid OpenPGP data found

I am behind a proxy , in apt.conf it is configured correctly

Acquire::http::Proxy "http://proxy.mycompany.de:3128";

I also tried setting proxy

export http_proxy="proxy.mycompany.de:3128"
export https_proxy="proxy.mycompany.de:3128"
share|improve this question
    
i think this solution can resolve your problem -> askubuntu.com/questions/23211/… another work around is gpg –keyserver hkp://keyserver.ubuntu.com:80 –recv-keys A258828C –  hhlp Feb 28 '11 at 16:13
    
sorry it's sudo gpg --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys A258828C –  hhlp Feb 28 '11 at 16:42

3 Answers 3

Try

export http_proxy=http://proxy.mycompany.de:3128; export https_proxy=$http_proxy
sudo -E apt-key adv --keyserver keyserver.ubuntu.com --recv-keys A258828C     
share|improve this answer
1  
it works, thanks so much! ( sudo -E is the key for me ) –  Siwei Shen May 15 '12 at 3:21

Did you forget to use sudo?

If you did and it failed, also try this:

sudo gpg --ignore-time-conflict --no-options --no-default-keyring --secret-keyring /etc/apt/secring.gpg --trustdb-name /etc/apt/trustdb.gpg --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyserver hkp://keyserver.ubuntu.com:80 --recv A258828C
share|improve this answer

Try running sudo -s before

apt-key adv --keyserver keyserver.ubuntu.com --recv-keys A258828C

This worked for me.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.