Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My laptop is a Lenovo Thinkpad T61 with intel graphics card running 13.04. I'm pretty sure that when my battery gets too low, the laptop suspends itself, but when i plug it back in, it won't come on. Actually, if I've been playing music or video, i can hear the sound, often glitching and skipping, but there is absolutely no response from the monitor. The indicator lights come on, as if the computer is running, but no buttons work provoke a response, except when I hold the power button down for an extended time to shut the computer off. Please help: almost everything else on the computer works perfectly. Thanks guys.

share|improve this question

5 Answers 5

I had this same problem. Upon reboot, I went into Ubuntu Advanced and changed linux boot kernel from 3.8.x to 3.5.x and I have no issue when rebooting. Hope this helps you as well.

share|improve this answer

I found the Nouveau display driver to be the problem Fix I did:

Go into software & Updates (search for this app with the Ubuntu "search your computer and online sources" top left menu, Ubuntu icon). Then go to "Additional Drivers" tab. Switch from "Using X.Org X server -Nouveau display driver..." to Using NVIDIA binary Xorg driver.. 310 (proprietary tested/) version and apply.

On the next reboot it suspended fine and has been working great ever since

share|improve this answer
    
This fixed the same issue for me (T61 with Nvidia Quadro NVS 140m), switched to the latest available Nvidia driver (331.38 at time of writing) –  FredL Aug 30 at 21:11

I've had similar sounding issues with hibernate. I've installed Gnome Ubuntu 13.04 on my T61 and tried to hibernate using TuxOnIce. It hibernates and resumes ok, but on resume the screen is frozen. I can see the screen as it was when I hibernated, but nothing moves, not even the mouse. I can't even CTRL-ALT-F2 to get to another session.

Exactly the same thing happens with suspend.

I had no problems hibernating with Ubuntu 12.04 or 12.10 (although sometimes gnome-shell used to hang on resume, I could always CTRL-ALT-F2 to another session and kill -9 gnome-shell to recover)

My T61 is a little different to the original poster's, it has an Nvidia NV140m rather than intel graphics. (I may also mention that I use encrypted swap, as per these instructions)

share|improve this answer

The problem in my case wasn't the wifi but the (open source) nouveau display driver. Replaced it with the (closed source) nvidia driver. Works like a charm now.

share|improve this answer

I have tried adding "modprob -r iwl4965" when lid closes and "modprob iwl4965" when it opens. Seems to fix the problem (maybe your wifi module is iwlwifi).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.