Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have read that many people using ubuntu on the T5xx laptops are having issues with slow wifi, but my issues is slightly different. My laptop very frequently drops connections, or takes a very long time to connect in the first place. The speeds are fine. I have a lenovo T520 running ubuntu 12.04.

Things I have done:

replaced the realtek card with the intel 6300 - Much better range, still same dropping issue

Assessed that this problem does not occur in windows.


This leads me to believe the issue lies somewhere in ubuntu. Does anyone have any suggestions on what may fix this issue?

Thanks

share|improve this question
    
Type in: "dmesg | tail -n 25" ... You will see how the kernel killed the wifi card. I know. T series user here. –  Shiki Apr 22 '13 at 16:34
    
just ran this after it dropped: saw a slew of output about the wireless card. is there a solution to this? –  gh123man Apr 22 '13 at 16:40
1  
Please see post #6 here. I believe you need the same fix: ubuntuforums.org/… –  chili555 Apr 22 '13 at 16:56
    
Just ran it, Ill give it an hour or so and report back. Thanks –  gh123man Apr 22 '13 at 17:02
    
Unfortunately it still appears to be dropping connections –  gh123man Apr 22 '13 at 19:54
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.