Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I totally ruined my Ubuntu 10.10 Desktop x64 installation today. I've never been able to hibernate or suspend (not with my laptop, server or htpc), not even through this guide. So I read a post here on askubuntu.com that said that the proprietary drivers may be in the way for it to work.

Therefore I removed my ATI-drivers, rebooted, then tried to hibernate the system. I got some error about "blk_something_something didn't work, resubmitting1". So I turned off the computer and then tried booting up. I see the ubuntu splash but after that I'm greeted with this screen:

My computer screen after booted up

The upper dot is the mouse pointer since I can move it with the mouse (I have ubuntu set to login automatically). I don't know how this happened.

What can I do to fix this? I'm getting seriously irritated over how buggy ubuntu is, why doesn't even suspend/hibernate work (remember that I have 3 different systems where it fails)?

So what is the next step? I want to get into cli mode and reinstall the driver but since I'm relatively new to ubuntu I don't know how to get into a terminal without logging in first. And if I press shift during boot I can't get into grub either and try something from there.

Please come with all suggestions you can think of!

Thank you very much!

edit: Can I use ubuntu on a usb to insert the driver I need - if that is the problem?

share|improve this question
    
Regarding the suspend/hibernate issues, do you have any USB 3.0 ports? See Suspend fails and I know the module causing it. What can I do? if you do. –  Lekensteyn Feb 28 '11 at 10:20
    
Only on the htpc, the server and laptop only have 2.0 ports. –  Niklas Feb 28 '11 at 10:23
add comment

1 Answer

up vote 2 down vote accepted

Try pressing Ctrl-Alt-F1 to get into console mode, login in using your normal credentials. Then you get a CLI where you can do what you want (Probably sudo apt-get install fglrx). You can switch back to the graphical desktop with Ctrl-Alt-F7.

share|improve this answer
    
When I press ctrl+alt+f7 I get a repeating error message stating: [ ~number increasing~] [drm:radeon_ib_schedule ERROR radeon: couldn't schedule IB(~number counting from zero up to 15~) –  Niklas Feb 28 '11 at 10:27
    
[ ~number increasing~] [drm:radeon_cs_ioct Faild to schedule IB ! –  Niklas Feb 28 '11 at 10:32
    
I put it into several comments to make it easier to read since the linebreaks got removed when I added the comment. I keep getting this error message and cannot make an input. What next? –  Niklas Feb 28 '11 at 10:33
    
(Update) I can make inputs even though the message keep appearing. I'll let you know if I make it work. –  Niklas Feb 28 '11 at 10:36
    
@ error messages: could be this bug: bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-ati/+bug/… –  Christoph Feb 28 '11 at 10:45
show 2 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.