Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried to install qt-sdk under ubuntu 12.10 how can I fix this issue?

install log:

apt-get install qt-sdk
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 qt-sdk : Depends: qt4-designer but it is not going to be installed
          Depends: qt4-dev-tools but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
share|improve this question
add comment

1 Answer

First do

sudo apt-get install qtcreator 
sudo apt-get install qt4-designer
sudo apt-get install qt4-dev-tools

then

sudo apt-get install qt-sdk

share|improve this answer
    
I didn't same steps as soon as I face this issue... it didn't fix it! –  mbnoimi Apr 21 '13 at 17:19
    
qtcreator already installed –  mbnoimi Apr 21 '13 at 17:20
    
Have you tried installing qt designer and dev tools? –  thefourtheye Apr 22 '13 at 3:05
    
when I tried to: sudo apt-get install qt4-designer I got this error message. –  mbnoimi Apr 22 '13 at 10:52
    
The following packages have unmet dependencies: –  mbnoimi Apr 22 '13 at 10:53
show 5 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.