Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I get following error while installing Cinnamon

sudo apt-get install cinnamon

Reading package lists... Done

Building dependency tree
Reading state information... Done

Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:

The following packages have unmet dependencies:

cinnamon : Depends: gir1.2-muffin-3.0 but it is not going to be installed

        Depends: libgjs0-libmozjs185-1.0 but it is not installable

        Depends: libgjs0c (>= 1.34.0) but 1.32.0-1ubuntu1 is to be installed

        Depends: libgnome-desktop-3-4 (>= 3.2.0) but it is not installable

        Depends: libmuffin0 (>= 1.1.1) but it is not going to be installed

        Recommends: gnome-themes-standard but it is not going to be installed

        Recommends: gnome-session-fallback but it is not going to be installed

        Recommends: nemo but it is not going to be installed

E: Unable to correct problems, you have held broken packages.

I tried everything on this:

How do I resolve unmet dependencies?

but still unable to install. Please help

share|improve this question

1 Answer 1

By adding the repositories required for cinnamon in this case type this in terminal,

sudo add-apt-repository ppa:merlwiz79/cinnamon-ppa

Then issue the should be fixed if you use 'sudo apt-get -f install (program name)' to get the missing packages. Which should work, But know to add ppa repo's use the above command. Of course replace the repository to the one you want.

share|improve this answer
    
It didn't work still. Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: gir1.2-muffin-3.0 : Depends: libmuffin0 (>= 1.1.2) but it is not going to be installed E: Unable to correct problems, you have held broken packages. –  Nachiket Apr 21 '13 at 8:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.