Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just recently installed 12.10 on a new Lenovo T430, and added these options in \etc\fstab:

discard, relatime

To \sda1 on which \ is installed. When I rebooted, I got an error claiming that it couldn’t read \, and got thrown into a read-only shell, which necessitated booting from a rescue disk to revert to the original fstab.

So: What are the correct options for SSD, and how can I make sure I won't get locked out of the system again?

share|improve this question
add comment

3 Answers

up vote 1 down vote accepted

For my own SSD I use discard, noatime which seems to work, but with the /etc/fstab you have to make sure that no spelling errors are present or it can halt boot-up...

During initial boot hold down SHIFT key and go into recovery mode and from there you can enable read/write by selecting fix repo's and then drop to prompt to fix your /etc/fstab file...

share|improve this answer
add comment

You used a backslash ("\") rather than a forward slash ("/"), which is not allowed on Uinux-like systems like Linux.

share|improve this answer
add comment

You should not add whitespace in the options list. discard,relatime should be used instead of discard, relatime. While you are at it, you can remove relatime since this is the default setting for recent kernels.

To fix this error, you can boot from a Live CD, mount your root partition and edit the /etc/fstab file with appropriate permissions.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.