Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I use emacs, I often end up typing many exciting key combinations which I would usually not use, such as C-M-t (i.e. Ctrl - Alt - T), which in emacs is supposed to run the command transpose-sexps; however, since X or Gnome (I'm not sure which) is catching this event, this has the actual effect of opening a Terminal. Nevertheless, I enjoy and am used to having the functionality to open a new Terminal—provided that I don't have emacs open. So, is there any way to temporarily disable all keyboard shortcuts whenever the current focus is on emacs?

N.B. I happen to be using the non-graphical version of emacs emacs-nox, so I in fact usually have a Terminal running emacs, not a graphical emacs window.

share|improve this question
add comment

1 Answer 1

Someone who uses Gnome will be able to help more, but see if Gnome does not have a UI for setting preferences that includes how certain key sequences are to be handled. It's likely that some keys are just grabbed by Gnome and there is nothing you can do about it, but it might be possible to tell Gnome "hands-off" for some other keys. Look around a little in your Gnome UI. And google a bit. Too bad no one else here has offered any better help yet, but hopefully they will.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.