Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Recently I installed Kubuntu (http://www.kubuntu.org/) to improve the speed of using Ubuntu. Neverhteless when I try to run my rails applications with the command "rails s" I get the following error:

The program 'rails' can be found in the following packages:
* rails
* ruby-railties-3.2

Rails is installed properly and I use it all the time when I use the desktop version of Kubuntu I get this errror...

share|improve this question
    
Try typing "which rails". Can you give us the output of "echo $PATH" please? Also, can you go into Synaptic, and in the rail package, find what files it has installed? In particular you want to find the main executable, and check if it's in your path. –  jmite Apr 21 '13 at 4:51
    
Hi @jmite thanks for the help. When I type "which rails" nothing happens. The output for "echoi $PATH" is this: /usr/local/heroku/bin:/usr/lib/lightdm/lightdm:/usr/local/sbin:/usr/local/bin:/‌​usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/home/ubuntu/.rvm/bin I am sorry I am new to programmnig I don't quite know how to find the executable and know if it is in my path. I tried to open the Synaptiks program but it won't open... –  Juan Camillo Abello Apr 21 '13 at 18:27
    
You want to do "sudo apt-get install synaptic", and when it's done installing, do "gksudo synaptic". You shouldn't need programming, synaptic is an alternative to the Ubuntu software centre. Search for the "rails" package, and right click it, then click properties. Note that synaptic, the package manager, shouldn't be confused with synaptics, the touchpad drivers. Confusing, I know. –  jmite Apr 21 '13 at 19:12
    
I followed your instructions. It says the status of the Rails package is "not installed". I try to look for installed files but it says "The list of installed files is only available for installed packages". –  Juan Camillo Abello Apr 21 '13 at 22:38
    
Did you try what I suggested in my answer below? If it worked, please mark the answer as accepted, and if it didn't, tell me the error and I can try to help debugging it. –  jmite Apr 23 '13 at 18:06
add comment

1 Answer

If Synaptic is saying that the package isn't installed, then it likely isn't, or possibly got removed. To install it, do

sudo apt-get install rails

or just right-click on the package in Synaptic and click "Install".

share|improve this answer
    
the problem is that rails is in fact running when I don't use Kubuntu but the normal Ubuntu desktop. I don't want to install it twice... –  Juan Camillo Abello Apr 25 '13 at 20:31
    
How did you install rails initially? Did you use the package manager, rbenv or RVM? If you used RVM, your terminal should be set to run as a login shell. I'm guessing GNOME-Terminal got this setting set at some point (it's not default), and Konsole (the default terminal emulator in Kubuntu) needs to have it set as well. I did some searching, and it seems that option isn't readily available in Konsole (unless I'm missing something). Perhaps you could try executing gnome-terminal from within KDE to see if rails works then. –  Jayson Rowe May 23 '13 at 3:01
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.