Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

What am I trying to do?

As the title suggests, I am trying to install the the Line 6 Toneport UX1 software.

What is the problem?

Upon reaching the step where I am told to enter sudo apt-get install linux-headers into Terminal in this article, I am confronted with the following message...

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package linux-headers is a virtual package provided by:
  linux-headers-3.5.0-27-lowlatency 3.5.0-27.30
  linux-headers-3.5.0-26-lowlatency 3.5.0-26.28
  linux-headers-3.5.0-25-lowlatency 3.5.0-25.25
  linux-headers-3.5.0-24-lowlatency 3.5.0-24.23
  linux-headers-3.5.0-23-lowlatency 3.5.0-23.22
  linux-headers-3.5.0-22-lowlatency 3.5.0-22.21
  linux-headers-3.5.0-21-lowlatency 3.5.0-21.19
  linux-headers-3.5.0-18-lowlatency 3.5.0-18.18
  linux-headers-3.5.0-27-generic 3.5.0-27.46
  linux-headers-3.5.0-27 3.5.0-27.46
  linux-headers-3.5.0-26-generic 3.5.0-26.42
  linux-headers-3.5.0-26 3.5.0-26.42
  linux-headers-3.5.0-25-generic 3.5.0-25.39
  linux-headers-3.5.0-25 3.5.0-25.39
  linux-headers-3.5.0-24-generic 3.5.0-24.37
  linux-headers-3.5.0-24 3.5.0-24.37
  linux-headers-3.5.0-23-generic 3.5.0-23.35
  linux-headers-3.5.0-23 3.5.0-23.35
  linux-headers-3.5.0-22-generic 3.5.0-22.34
  linux-headers-3.5.0-22 3.5.0-22.34
  linux-headers-3.5.0-21-generic 3.5.0-21.32
  linux-headers-3.5.0-21 3.5.0-21.32
  linux-headers-3.5.0-19-generic 3.5.0-19.30
  linux-headers-3.5.0-19 3.5.0-19.30
  linux-headers-3.5.0-18-generic 3.5.0-18.29
  linux-headers-3.5.0-18 3.5.0-18.29
  linux-headers-3.5.0-17-lowlatency 3.5.0-17.18
  linux-headers-3.5.0-17-generic 3.5.0-17.28
  linux-headers-3.5.0-17 3.5.0-17.28
You should explicitly select one to install.

E: Package 'linux-headers' has no installation candidate

What have I done?

I've gone through the list of linux-headers (e.g. sudo apt-get install linux-headers-3.5.0-27-lowlatency 3.5.0-27.30 and onward) and I receive a message that reads as follows:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package x.x.x-x.x
E: Couldn't find any package by regex 'x.x.x-x.x'

Granted this article may be pretty old, I think perhaps the final line E: Package 'linux-headers' has no installation candidate means they could've been taken down.

My specifications

  • Ubuntu 12.10
  • OS type: 64 bit
share|improve this question
    
Any reason you split this into two questions, which isn't acceptable here? (I've edited your part 2 into this question here) –  Thomas W. Apr 27 '13 at 20:38
    
@TheLordofTime It is a separate question. The software did install properly, but it's actually a problem with the VirtualBox and USB port settings. This question was about installation in the Terminal. –  mdeitrick Apr 27 '13 at 20:42
    
then you should not split them in parts, but rather say "This is a different question". The titles suggested "merging". I rolled back my edits, but you need to state the difference in the questions –  Thomas W. Apr 27 '13 at 20:43
    
@TheLordofTime Okay, sorry. –  mdeitrick Apr 27 '13 at 20:44
add comment

1 Answer

up vote 0 down vote accepted

Gah, I can't believe I missed this...

uname -r

That command will display the version to install. Everything is very straightforward after that.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.