Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm new to Linux and am having terrible difficulty getting my bluetooth devices to pair/connect. I'm using a bluetooth dongle on my Dell Inspiron 910 running Lubuntu 12.04.2 LTS. I've tried blueman bluetooth manager and bluetooth-applet (which I think came preinstalled with Ubuntu) but both crash my system whenever I attempt to pair/connect devices.

I don't fully understand it at this point but I've read that there is a problem with the bluez package/stack. There doesn't seem to be much support availbable the subject. At this point I'm completely unsure as to what package I should be using for bluetooth functionality or what packages I need to have installed/uninstalled. If you could point me in the right direction I'd be very greatful. I recently bought a Logitech K810 keyboard which I can only stare at for the moment.

share|improve this question
add comment

1 Answer 1

I have the same problem with this nice piece of hardware. Pairing fails after entering the PIN. The keyboard reacts on the ENTER key. The message: pairing fails - with the following entries in the sys log:

Apr 30 13:19:16 wetab bluetoothd[889]: Discovery session 0xb9639b68 with :1.48 activated Apr 30 13:19:32 wetab bluetoothd[889]: Stopping discovery Apr 30 13:19:33 wetab bluetoothd[889]: Unknown Management opcode 23 (index 0) Apr 30 13:19:43 bluetoothd[889]: last message repeated 6 times Apr 30 13:19:43 wetab bluetoothd[889]: hci0: Cancel Pair Device (0x001a) failed: Invalid Parameters (0x0d)

I managed to use the keyboard anyway - with some drawbacks.

Just: hidd --search

one need to install sudo apt-get install bluez-compat

OK, every restart I have to press the pairing button and start the command again. I do not trust the encryption either. But at least I can work. I use a fresh Raring Ringtail installation which works just fine with my very cheap rubber bluetooth keyboard...

Hope it gets better later as it seems to be an implementation flaw in Linux as the K810 works fine with my Android.

Conrad

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.